Architecting, installing and maintaining your SAS environment

SAS VA Error Message? Failed to retrieve facets info?

Accepted Solution Solved
Reply
Frequent Contributor
Posts: 90
Accepted Solution

SAS VA Error Message? Failed to retrieve facets info?

Hello all,

Can anyone help me with this error?  Failed to retrieve facets info

 

The full message is:

 

Search Interface to SAS Content encountered error while feeding the content to the Indexing Server

Error Message: com.sas.svcs.search.client.IndexServiceException: Failed to retrieve facets info HOST: mysever.com Check Web Application Server logs for more details. Once the issue is resolved, please check Integrating Search Interface to SAS Content document for - How to recover lost data for Indexing Server after Indexing Failure under FAQ section.

I am getting these via email 3-5 times a day from my SAS VA server, for a while now.  We loaded the server a while back, did some training but have not really used it since its going to be a big summer push to start using it.  I don't think we have changed a thing of it save upgrade the OS as patches come out, and let it be...

TIA  -KJ


Accepted Solutions
Solution
‎08-18-2017 07:48 AM
PROC Star
Posts: 425

Re: SAS VA Error Message? Failed to retrieve facets info?

Posted in reply to kjohnsonm

Are you using HTTPS with certificate that requires the CA to be added to the SAS trusted CA bundle?

 

I ask because I had the same "Failed to retrieve facets info" error today with a new SAS VA 7.4 installation using a server certificate from a custom CA. I had already used SAS Deployment Manager to add the custom CA to the trusted CA bundle after install but before deployment. However, it seems there was a manual post-deployment step I missed.  I discovered this by finding SAS Usage Note 59133: Tips for troubleshooting problems with the search functionality from SAS Home specifically the section "Were the steps to enable SAS Information Retrieval Studio to work with TLS encryption completed?" That in turn led me to the instructions in the Post-Deployment Tasks for SAS Information Retrieval Studio section of the SAS® Visual Analytics 7.4: Installation and Configuration Guide (Distributed SAS® LASR(TM)). After following these instructions I could start the Query Server without it stopping immediately afterwards and the facets error was no longer generated.

 

I also noticed that the SAS note and documentation refers to a distributed deployment but in my case this step was also needed for a non-distributed deployment. The SAS® Visual Analytics 7.4: Installation and Configuration Guide (Non-distributed SAS® LASR(TM)) documentation does not appear to have an equivalent Post-Deployment Tasks for SAS Information Retrieval Studio page.

View solution in original post


All Replies
Frequent Contributor
Posts: 90

Re: SAS VA Error Message? Failed to retrieve facets info?

[ Edited ]
Posted in reply to kjohnsonm

PS I have looked all over for a fix but am not getting any hits on it via google.com searches or at SAS.com and I looked closer at the email frequency, it looks like it is hitting every 4 hours through out the day.

SAS Super FREQ
Posts: 299

Re: SAS VA Error Message? Failed to retrieve facets info?

Posted in reply to kjohnsonm

Hi,

 

I believe Tech Support suggested the following SAS Note to you:  http://support.sas.com/kb/54/579.html

Have you looked at it, did it help solving the problem?

 

Thanks

Anja

Frequent Contributor
Posts: 90

Re: SAS VA Error Message? Failed to retrieve facets info?

anja wrote:

Hi,

 

I believe Tech Support suggested the following SAS Note to you:  http://support.sas.com/kb/54/579.html

Have you looked at it, did it help solving the problem?

 

Thanks

Anja

Well step four most certainly stops the emails messages, but I am not sure its helps fix the underlining problem or if it’s a false positive error.  And thus this steps is the best action.

Disable the Alert E-mails in SAS® Management Console

  1. Log on to SAS Management Console with the SAS Administrator account.
  2. In SAS Management Console, select Application Management ► Coniguration Manager.
  3. Right-click Search Interface to SAS Content 3.3 and select Properties.
  4. On the Advanced tab in the Search Interface to SAS Content 3.3 Properties dialog box, set searchas.notification.email.is_active to false, as shown below.

However the service this kb references does not seem to stay running for some reason that I do not yet understand... and this seems to be the root of the problem.   …and as for the part about using web page http://myserver:10651 that does not respond at all but the fire wall is off, 'netstat –an' show the system listening on the port and I am attempting the web page from a browser on the server itself with localhost:10651 and 127.0.0.1:10651 and it does not respond…   have a great day!

Thanks for the post.

 

 

 

Solution
‎08-18-2017 07:48 AM
PROC Star
Posts: 425

Re: SAS VA Error Message? Failed to retrieve facets info?

Posted in reply to kjohnsonm

Are you using HTTPS with certificate that requires the CA to be added to the SAS trusted CA bundle?

 

I ask because I had the same "Failed to retrieve facets info" error today with a new SAS VA 7.4 installation using a server certificate from a custom CA. I had already used SAS Deployment Manager to add the custom CA to the trusted CA bundle after install but before deployment. However, it seems there was a manual post-deployment step I missed.  I discovered this by finding SAS Usage Note 59133: Tips for troubleshooting problems with the search functionality from SAS Home specifically the section "Were the steps to enable SAS Information Retrieval Studio to work with TLS encryption completed?" That in turn led me to the instructions in the Post-Deployment Tasks for SAS Information Retrieval Studio section of the SAS® Visual Analytics 7.4: Installation and Configuration Guide (Distributed SAS® LASR(TM)). After following these instructions I could start the Query Server without it stopping immediately afterwards and the facets error was no longer generated.

 

I also noticed that the SAS note and documentation refers to a distributed deployment but in my case this step was also needed for a non-distributed deployment. The SAS® Visual Analytics 7.4: Installation and Configuration Guide (Non-distributed SAS® LASR(TM)) documentation does not appear to have an equivalent Post-Deployment Tasks for SAS Information Retrieval Studio page.

Frequent Contributor
Posts: 90

Re: SAS VA Error Message? Failed to retrieve facets info?

Posted in reply to PaulHomes

PaulHomes wrote:

"Are you using HTTPS with certificate that requires the CA to be added to the SAS trusted CA bundle?

 

I ask because I had the same "Failed to retrieve facets info" error today with a new SAS VA 7.4 installation using a server certificate from a custom CA. I had already used SAS Deployment Manager to add the custom CA to the trusted CA bundle after install but before deployment. However, it seems there was a manual post-deployment step I missed.  I discovered this by finding SAS Usage Note 59133: Tips for troubleshooting problems with the search functionality from SAS Home specifically the section ..."



I was just a small part of the install on this, we had SAS consultants and other Server Admin types locally, and myself for the local application support.   I will have to research your idea.  Thank you for responding.   -KJ

 

Frequent Contributor
Posts: 90

Re: SAS VA Error Message? Failed to retrieve facets info?

Posted in reply to kjohnsonm

The certs seem to be okay. I can only guess that at this time our network security is to tight, it might be blocking the port part of this fix. I cannot access this web page from my PC, or from the secure network, or the server in the secure network. I cannot access that part of the webpage even with the config changes and the server rebooted. I am not sure if I have the URL correct for my needs however have tried many variations of the URL, with or without http/https on the server itself too. This last part on the server has me confused. I was thinking that the http(s)://localhost:10651 with or without the 's' would have to work. It does not on the server.

 

Is there a "login" URL page I have to connect with for this port?

 

I can access pages like https://{myserver.mydomain}/SASVisualAnalyticsHub/ and have added variations of this url to my testing in or out of the secure network...

TIA -KJ

Frequent Contributor
Posts: 90

Re: SAS VA Error Message? Failed to retrieve facets info?

Posted in reply to kjohnsonm

Oops it does say on one varication on the server directly

'SAS Information Retrieval Studio is working'

but that page shown in the kb does not come up or does it give me a login or link to use of any kind.  I have no idea what that means.

PROC Star
Posts: 425

Re: SAS VA Error Message? Failed to retrieve facets info?

Posted in reply to kjohnsonm

Did you follow the instruction in that SAS Usage Note 59133 regarding adding enable-web-admin-interface=true to the end of information-retrieval-studio.conf and restarting SAS Information Retrieval Studio?

 

Additionally I found that whilst most of the SAS web apps were accessible via HTTPS the SAS Information Retrieval Studio app on port 10651 was still HTTP (i.e. http://server.example.com:10651/).

Frequent Contributor
Posts: 90

Re: SAS VA Error Message? Failed to retrieve facets info?

Posted in reply to PaulHomes

"enable-web-admin-interface=true to the end of information-retrieval-studio.conf " Yes + 'java script enabled on server browser', I get the page responding but not form like they show.  I get that message saying 'SAS Information Retrieval Studio is working' and nothing else.  I'm still not sure what it implys getting this message and not the proper form.  Of course that was from the server remote desktop and its IE browser.   I have since turned java script back off, howerver have left the true setting.

Frequent Contributor
Posts: 90

Re: SAS VA Error Message? Failed to retrieve facets info?

Posted in reply to kjohnsonm
PS Paul thanks for your time -KJ
PROC Star
Posts: 425

Re: SAS VA Error Message? Failed to retrieve facets info?

Posted in reply to kjohnsonm

Perhaps you can post a screenshot of what you see when you access http://yourserver.example.com:10651/ so we can compare it to what would be expected.

 

I see the following:

 

Selection_044.png

PROC Star
Posts: 425

Re: SAS VA Error Message? Failed to retrieve facets info?

[ Edited ]
Posted in reply to PaulHomes

Actually, I think I know what you are talking about now. I did a quick test and removed enable-web-admin-interface=true from information-retrieval-studio.conf, restarted the service and went to http://yourserver.example.com:10651/ and now I see the plain message:

 

Selection_045.png

 

So I suspect that you either made a mistake in adding enable-web-admin-interface=true to information-retrieval-studio.conf or omitted a restart of the service.

 

You can stop and start the service with something similar to:

 

/opt/sasva74/Applications/SASInformationRetrievalStudioforSAS/IRStudio.sh stop
/opt/sasva74/Applications/SASInformationRetrievalStudioforSAS/IRStudio.sh start

 

New Contributor
Posts: 4

Re: SAS VA Error Message? Failed to retrieve facets info?

Posted in reply to PaulHomes

Hi, PaulHomes, 

 

I think that I face exactly the problem you mentioned here:

====

I ask because I had the same "Failed to retrieve facets info" error today with a new SAS VA 7.4 installation using a server certificate from a custom CA. I had already used SAS Deployment Manager to add the custom CA to the trusted CA bundle after install but before deployment. However, it seems there was a manual post-deployment step I missed.  I discovered this by finding SAS Usage Note 59133: Tips for troubleshooting problems with the search functionality from SAS Home specifically the section "Were the steps to enable SAS Information Retrieval Studio to work with TLS encryption completed?" That in turn led me to the instructions in the Post-Deployment Tasks for SAS Information Retrieval Studio section of the SAS® Visual Analytics 7.4: Installation and Configuration Guide (Distributed SAS® LASR(TM)). After following these instructions I could start the Query Server without it stopping immediately afterwards and the facets error was no longer generated.

====

My Query Server stops immedidately after I manually start it. So I read the " Post-Deployment Tasks for SAS Information Retrieval Studio section of the SAS® Visual Analytics 7.4: Installation and Configuration Guide (Distributed SAS® LASR(TM))." In it it mentions 

 

In the third maintenance release for SAS 9.4 and later:
tkpath=/SAS-installation-directory/SASFoundation/9.4/sasexe:
/SAS-installation-directory/SASFoundation/9.4/utilities/bin/
auth-server-certificates-path=SAS-installation-directory/
SASSecurityCertificateFramework/1.1/cacerts/trustedcerts.pem

 Is the above 'tkpath' it has 4 lines. Should I enter the above in four lines or in one line? If it is one line, is there any space between 'sasexe' and '/SAS-install...'? Any space between 'utilities/bin/' and 'auth-server...'?  Maybe you can simple show me your 'tkpath' in your information-retrieval-studio.conf.

 

BTW, my system is also 'non-distributive'. 

 

Thanks

Jim 

 

New Contributor
Posts: 4

Re: SAS VA Error Message? Failed to retrieve facets info?

Hi, PaulHomes, 

 

Sorry to bother you with my questions, I should simply try it myself. The following 'takpath' and 'auth-server-certificates-path' are two lines. 

In the third maintenance release for SAS 9.4 and later:
tkpath=/SAS-installation-directory/SASFoundation/9.4/sasexe:
/SAS-installation-directory/SASFoundation/9.4/utilities/bin/
auth-server-certificates-path=SAS-installation-directory/
SASSecurityCertificateFramework/1.1/cacerts/trustedcerts.pem

 After adding the above two lines. Now my Query Server keeps 'running' after I manually start it. Before the Query Server would immediately stops after I manually start it. 

 

Thank you so much! 

Jim 

☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 15 replies
  • 778 views
  • 2 likes
  • 4 in conversation