Architecting, installing and maintaining your SAS environment

SAS VA Distribute Report says recipient was not found.

Accepted Solution Solved
Reply
New Contributor
Posts: 4
Accepted Solution

SAS VA Distribute Report says recipient was not found.

Running SAS VA 7.3 single server install on Linux using Windows AD authentication.  I'm trying to use the Distribute Reports option when in Report Designer.  Users are setup with e-mail addresses, and setup with AD accounts (not internal accounts).  Some users can receive the report, and others come back as recipient not found.  I get, "WARN | LOGON_USERS | Cannot locate user (UserName) (Root Cause:   java.lang.IndexOutOfBoundsException: Index: 0, Size: 0 at java.util.ArrayList.rangeCheck(ArrayList.java:635)" in the Distribution job completion summary e-mail.  I'm unable to determine the differences between accounts that would cause this.  It's not a matter of not having access to the report or data, because the process doesn't even get that far.  I created a test account, and cannot get it to work.  I've made sure the account has logged into SAS.  I also made sure the AD account assigned to the SAS account has logged into the Linux server.  I don't know what to do or look at from here.


Accepted Solutions
Solution
‎07-05-2017 01:27 PM
New Contributor
Posts: 4

Re: SAS VA Distribute Report says recipient was not found.

So, not having the AD accounts was the problem.  Once the AD accounts were setup, I had to delete the SAS accounts and recreate them, but then I was able to send reports to the users.  Thanks for the help and suggestions.

View solution in original post


All Replies
SAS Employee
Posts: 115

Re: SAS VA Distribute Report says recipient was not found.

@BSchellenger,

 

The only time I have seen that error in distribution is when the recipient was an internal account. Are you sure that you are not using an internal account? Also, what errors you have in SASVisualAnalyticsHyperlink.log?

 

SAS Usage Note 55920: Tips for troubleshooting problems with the distribution functionality in SAS® ...

SAS Super FREQ
Posts: 437

Re: SAS VA Distribute Report says recipient was not found.

Can you successfully send email to those users? In SAS Visual Analytics Designer, select File > Email. If you see an error in designer or in either the hyperlink or designer log, then please post them.

 

  • /SAS-configuration-directory/Lev1/Web/Logs/SASServerX_Y/SASVisualAnalyticsDesigner7.x.log

 

  • /SAS-configuration-directory/Lev1/Web/Logs/SASServerX_Y/SASVisualAnalyticsHyperlink7.x.log

 

If you do not see errors anywhere in Visual Analytics, then see if you get an "undeliverable" bounce back message from your email server.

New Contributor
Posts: 4

Re: SAS VA Distribute Report says recipient was not found.

I think I finally figured out the problem.  The AD accounts assigned to the SAS accounts were never setup, so they don't actually exist in AD.  I'm waiting for the AD accounts to be setup to test and make sure that fixes the problem.

Solution
‎07-05-2017 01:27 PM
New Contributor
Posts: 4

Re: SAS VA Distribute Report says recipient was not found.

So, not having the AD accounts was the problem.  Once the AD accounts were setup, I had to delete the SAS accounts and recreate them, but then I was able to send reports to the users.  Thanks for the help and suggestions.

☑ This topic is SOLVED.

Need further help from the community? Please ask a new question.

Discussion stats
  • 4 replies
  • 227 views
  • 2 likes
  • 3 in conversation