Architecting, installing and maintaining your SAS environment

SAS Studio 3.5 mid-tier time-out global setting

Reply
Contributor
Posts: 20

SAS Studio 3.5 mid-tier time-out global setting

We're trying to change the default Time-out interval for SAS Studio 3.5. The end-user can adjust this in SAS Studio Preferences > General tab. I've found several posts (including here) saying it can be done globally, but I cannot find a "webdms" property to control default time-out. Only this one "webdms.maxSessionTimeoutInHours", see "SAS Studio 3.5: Administrator's Guide, Second Edition".

 

Can someone please tell me what the propety name is (if it exists)?

 

Thanks,

Lance

Trusted Advisor
Posts: 1,141

Re: SAS Studio 3.5 mid-tier time-out global setting

Hello @lanceanz,

 

names of variables might be improved and change between versions. I would say that the one you found is the correct one. if you change it and restart the SASStudio web application (or its application server) it should be working.

 

Did you read already this thread? https://communities.sas.com/t5/Administration-and-Deployment/timeout-interval-in-SAS-Studio/td-p/284...

Contributor
Posts: 20

Re: SAS Studio 3.5 mid-tier time-out global setting

Hello Juan,

 

Thanks for replying. Yes, I reviewed that thread prior to posting. The value of 'webdms.maxSessionTimeoutInHours' is set to the default of 240 on our site, which doesn't tally with the default timeout of 1 hour in SAS Studio. When change the Session time-out value in SAS Studio Preferences > Start Up, anything over 240 gives "This value is out of range". So I'm pretty confident the setting name is accurate.

 

As we onboard new server users we are now telling them to change the setting in SAS Studio, but not everyone reads our advice! It's turned out to be the biggest new-user annoyance. They like Batch Submit, but also want to go to lunch and leave an interactive session running. I've not yet suggested shorter lunch breaks Smiley Wink

 

Lance

Ask a Question
Discussion stats
  • 2 replies
  • 163 views
  • 0 likes
  • 2 in conversation