Architecting, installing and maintaining your SAS environment

SAS Security Administration Module

Reply
Super Contributor
Posts: 387

SAS Security Administration Module

Hi,

What is the SAS Security Administration Module?  I've Googled and searched support.sas.com.  Not a lick of documentation on this module (at least that I can find).

Second, should I be concerned if it doesn't install correctly?  What would be the results if it's not installed correctly?

The mid-tier install (using my plan file) fails with this error:

Property "secadminevm.dependson.admappmid.fqid" has not been set

If I install without selecting this module, then install only this module a second time, it installs successfully.  Is it possible the plan file has the order of component installation wrong?

I realize some of this is "contact Tech Support".  But, if you can at least tell me what the module *is*, that would be helpful.  Even more helpful would be a pointer to some documentation.

Thanks,

Scott

Community Manager
Posts: 406

Re: SAS Security Administration Module

Posted in reply to ScottBass

You experienced a known problem that exists in software deployment plans that are generated before August 2014.  The workaround is to generate a new plan file, or use a plan file that was created since that time.  The SAS Security Administration Module is an internal component that is used by other applications, such as SAS Environment Manager.

Occasional Contributor
Posts: 12

Re: SAS Security Administration Module

Posted in reply to ShelleySessoms

I received this error today.  My environment had SAS VA 6.3 with SAS 9.4_M1 and I updated/upgraded to SAS VA 7.2 wit SAS 9.4_M2 last month.  My environment had Lev1, Lev2 and Lev3.  I had to reconfigure my Lev2 due to some problems and I used the original plan file that was used for VA 6.3 installation.

Thanks and regards,
Jitendra Pandey
SAS Employee
Posts: 34

Re: SAS Security Administration Module

Posted in reply to jitendra_pandey

If your redeployment was at 7.2 you need to get and use a 7.2 plan file. It is a shortcoming of the SAS Deployment Wizard that it does/can not check the version of every product being installed against the plan, but instead assumes the order being used is the same one used to produce the plan file. 

Ask a Question
Discussion stats
  • 3 replies
  • 735 views
  • 2 likes
  • 4 in conversation