Architecting, installing and maintaining your SAS environment

SAS RTM nodes are not displaying for monitoring

Reply
Contributor
Posts: 35

SAS RTM nodes are not displaying for monitoring

In SAS Platform RTM no nodes are displaying for monitoring. Jobs are submitting to servers but to monitor that jobs in RTM couldn't find any nodes. RTM Server is recently rebooted. I checked all setting didn't find any issues with settings.

SAS Super FREQ
Posts: 291

Re: SAS RTM nodes are not displaying for monitoring

Hi,

 

has this ever worked? Is it a new environment?

 

Things to check are if license expired, ports have been changed and are not available for Grid anymore,

changes in config files? Also, do you have admin permissions to actually see the Nodes, or, are you logged on as user?

 

Do you receive any error messages or warnings?

 

My recommendation is to address this with SAS Tech Support. They can troubleshoot with you and guide you

into the right direction.

 

Thanks

Anja

Contributor
Posts: 35

Re: SAS RTM nodes are not displaying for monitoring

Our environment is very old its been working for 2 years. I am admin I have all permissions. It shows any errors. Licence is valid till 3DEC2016.

SAS Super FREQ
Posts: 291

Re: SAS RTM nodes are not displaying for monitoring

Hi,

 

some more info is needed to narrow down the problem:

just to clarify, it was working the entire time and without any applicable reason, the nodes dont show anymore?

 

Has there been any maintenance release update, hotfixes, OS update - anything that might change underlying

config files?

 

Thanks

Anja

Contributor
Posts: 35

Re: SAS RTM nodes are not displaying for monitoring

It is working well until last week. But due to some reasons, mysqld service is stopped, when it happened I couldn't able to open RTM interface. After starting mysqld I could open RTM interface. When I open RTM interface to monitor nodes it didn't displayed. Again I checked all services 

for service httpd status it is showing as "https is dead but subsys is locked". Asked Linux to restart services they said they did but still showing the same error.

Not sure this error is related to nodes not displaying.

SAS Super FREQ
Posts: 291

Re: SAS RTM nodes are not displaying for monitoring

Hi,

 

this error message can indicate a permission problem on the OS side!

 

Also, you could ask your IT folks to check whether the lock for a running service has been removed or is still showing as locked.

If it does, the lock file has to be manually removed.

Some background:

When the service is started, a lock file is created. This lock file is automatically deleted whenever the service stops.

If for whatever reason this lock file did not get deleted, the error message you are seeing would occur.

 

Thanks

Anja

Contributor
Posts: 35

Re: SAS RTM nodes are not displaying for monitoring

where is lock file created and in which location

Ask a Question
Discussion stats
  • 6 replies
  • 502 views
  • 0 likes
  • 2 in conversation