Architecting, installing and maintaining your SAS environment

SAS Management console does not show properties of libraries/connections

Accepted Solution Solved
Reply
Regular Contributor
Posts: 244
Accepted Solution

SAS Management console does not show properties of libraries/connections

MC1.PNG

MC2.PNG

 

 

I can't see the properties of my library or my connection to SAP BW. We only have this on our production server, not on the others..

 

any idea's? 


Accepted Solutions
Solution
‎04-09-2018 08:19 AM
SAS Employee
Posts: 199

Re: SAS Management console does not show properties of libraries/connections

Hi @Filipvdr

 

First, you may want to check the log, available from %appdata%\SAS\SASManagementConsole\9.4

If there isn't any helpful information, please turn on debug with Usage Note 43157 (Capturing debugging messages from SAS® Management Console).

 

Overall, without jumping to conclusion, it's possible that the issue is caused by a corrupt resource template.

Before proceeding with below steps, please ensure you have a backup.

 

Once the backup has completed and you have verified that it was successful, please do the following:

1- Log into SAS Management Console as your unrestricted admin user (eg. sasadm@saspw).
2- Expand the Metadata Manager plug-in and click on the Resource Templates folder.
3- In the right pane, scroll down until you see the SAP Library template. Right-click on it and choose "Delete".
4- In the left pane, right-click on the Resource Templates folder and choose "Add Resource Template".
5- In the first screen of the wizard, leave "Typical" selected and click "Next".
6- In the next screen, expand Libraries, expand Enterprise Applications Data.
7- Select SAP Library and click Next.
8- Click Finish to re-load the template.

 

template.PNG

 

Does that give you access to the Properties ?

 

Hope that helps.


Cheers,
Damo

View solution in original post


All Replies
Solution
‎04-09-2018 08:19 AM
SAS Employee
Posts: 199

Re: SAS Management console does not show properties of libraries/connections

Hi @Filipvdr

 

First, you may want to check the log, available from %appdata%\SAS\SASManagementConsole\9.4

If there isn't any helpful information, please turn on debug with Usage Note 43157 (Capturing debugging messages from SAS® Management Console).

 

Overall, without jumping to conclusion, it's possible that the issue is caused by a corrupt resource template.

Before proceeding with below steps, please ensure you have a backup.

 

Once the backup has completed and you have verified that it was successful, please do the following:

1- Log into SAS Management Console as your unrestricted admin user (eg. sasadm@saspw).
2- Expand the Metadata Manager plug-in and click on the Resource Templates folder.
3- In the right pane, scroll down until you see the SAP Library template. Right-click on it and choose "Delete".
4- In the left pane, right-click on the Resource Templates folder and choose "Add Resource Template".
5- In the first screen of the wizard, leave "Typical" selected and click "Next".
6- In the next screen, expand Libraries, expand Enterprise Applications Data.
7- Select SAP Library and click Next.
8- Click Finish to re-load the template.

 

template.PNG

 

Does that give you access to the Properties ?

 

Hope that helps.


Cheers,
Damo

Regular Contributor
Posts: 244

Re: SAS Management console does not show properties of libraries/connections

Thanks for the tips already, I will go through the log files.

We have it for every library in production environment, not only those which are linked to SAP.
Regular Contributor
Posts: 244

Re: SAS Management console does not show properties of libraries/connections

Thanks Damo, this worked for us!
☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 3 replies
  • 140 views
  • 1 like
  • 2 in conversation