Architecting, installing and maintaining your SAS environment

SAS Enterprise Guide 6.1 -> No Connection to MetaData Server

Reply
Occasional Contributor
Posts: 13

SAS Enterprise Guide 6.1 -> No Connection to MetaData Server

Hi,

I installed SAS 9.4 Data Management on a Windows Server 2008 R2 and SAS 9.4 Enterprise Guide 6.1 on a Client with Windows 7. After that I have checked all Servers and DI-Studio connection from a Client worked without problems.

Then I created a connection profile in the eGuide (used IWA)  and tried to connect to the MetaData Server. When I marked the profile as an active profile I got the following message:

No Connection to the MetaData Server possible

Detail message:

Library not registered

Can somebody help me to solve this problem because I tried several things and nothing worked?

Patrick 

Trusted Advisor
Posts: 3,215

Re: SAS Enterprise Guide 6.1 -> No Connection to MetaData Server

can you determine whether it is DLL (windows library) is failing or it is a SAS library (why?) that goes wrong.

It is strange as you did have connection with DI (java client) with that user and not with eguide (.Net).

---->-- ja karman --<-----
Occasional Contributor
Posts: 13

Re: SAS Enterprise Guide 6.1 -> No Connection to MetaData Server

No, there is no more information about the library in the error message.

I installed the eGuide not as an BI-Deployment but as a local Foundation installation.

In the SEGuide.register.log of this installation is a message

Could not load type library from C:\Program Files\SASHome 9.4\SASEnterpriseGuide\6.1\SASEGScripting.dll


Trusted Advisor
Posts: 3,215

Re: SAS Enterprise Guide 6.1 -> No Connection to MetaData Server

You could google on SASEGScritping.dll  it is a windows DLL and being expected on that location. I am guessing it is not there at hat location.

Either this is because of the way you did your installation, or there is something different. IT could be those dll's are added as part of the BI-deployment and not with the local foundation deployment.

There must be a MSI packge also (9.4 what is new). You must be able to talk with this information to SAS TS.  

---->-- ja karman --<-----
Super User
Posts: 3,257

Re: SAS Enterprise Guide 6.1 -> No Connection to MetaData Server

How about just trying a re-install of SAS EG to see if that helps? Or even try it on a different PC if there is one available.

Occasional Contributor
Posts: 13

Re: SAS Enterprise Guide 6.1 -> No Connection to MetaData Server

I solved the problem. It was the fact that I installed the SAS eGuide via a local SAS Foundation. This installation has not all features which are necessary to work with the servers (meta data Server, workspace server etc.). I deinstalled the eGuide and installed it via a 2-Machine Deployment Plan on the server and on the client.

Now it works.

Thank you Jaap!! You turned me in the right direction.

Ask a Question
Discussion stats
  • 5 replies
  • 973 views
  • 0 likes
  • 3 in conversation