Architecting, installing and maintaining your SAS environment

SAS Eminer issue:

Reply
Occasional Contributor
Posts: 17

SAS Eminer issue:

Hi,

 

When a user runs the libname statement in EG, he is able to assign it. But the same libname when he tried in E-Miner it shows the error like 

 

ERROR: Libref XXX not assigned

ERROR: Error in the libname statement

ERROR: Invalid credentials 

ERROR: Access denied

 

We have the checked all the metadata access and he has all the permission for the particular authdomain where he tries to connect to Teradata

 

libname model TERADATA authdomain="bi_Tera_BI360-DataLabUserRead_Auth" server=TDPRD schema="bi_model".

 

What might be the rootcause for this error

 

Regards,

Aravind

Trusted Advisor
Posts: 1,312

Re: SAS Eminer issue:

Posted in reply to AravindPalanichamy
Occasional Contributor
Posts: 17

Re: SAS Eminer issue:

Posted in reply to JuanS_OCS

Yes i have read these links. And i just want to add one more point here is all the other users are able to access this library (teradata libname) only a particular is not able to.

 

And i have replicated the same permission access levels similar to the one user who is able to assign that libname.

 

Only this user is not able to access.

 

 

Trusted Advisor
Posts: 1,312

Re: SAS Eminer issue:

[ Edited ]
Posted in reply to AravindPalanichamy

I guess we are missing an important detail here. The message you see is happening most likely because the Authenticantion Domain is not resolving to the proper values for this user. 

 

So I can think:

 

- SAS EG is assigning the Teradata library through metadata or an autoexec? Both with an Auth Domain?

- SAS EG and Miner are working under the same workspace and SASApp server, or different ones?

- Is the user providing all the connection details the same on EG and Miner?

- Less important, but worthy if previous don't give an answer: Is this happening to the user wether he logs in from one computer, or even a different computer?

- Have you tried to extend the logs to a Debug level?

Occasional Contributor
Posts: 17

Re: SAS Eminer issue:

Posted in reply to JuanS_OCS

Hi

 

Please find my answers below.

 

SAS EG is assigning the Teradata library through metadata or an autoexec? Both with an Auth Domain?

- Through autoexec, yes both with auth domain

SAS EG and Miner are working under the same workspace and SASApp server, or different ones?

- Yes same workspace server

Is the user providing all the connection details the same on EG and Miner?

- Yes same connection details.

Less important, but worthy if previous don't give an answer: Is this happening to the user wether he logs in from one computer, or even a different computer?

- I didnt checked in that way but i asked other User who has same access to login in to this user computer and checked, other user is able to access in his computer

Have you tried to extend the logs to a Debug level?

- No tat will not be possible as this is production environment it may lead to more logging and utilize more space.

Occasional Contributor
Posts: 17

Re: SAS Eminer issue:

Posted in reply to AravindPalanichamy
Any update on this
Trusted Advisor
Posts: 1,312

Re: SAS Eminer issue:

Posted in reply to AravindPalanichamy

Hi,

 

this behavious sounds a bit strange, and I cannot give you additional insight, sorry.

 

And since nobody else could answer your question, I would strongly advise you to contact SAS Technical Support or the SAS Consulting team to support your issue.

 

Best regards,

Juan

SAS Super FREQ
Posts: 299

Re: SAS Eminer issue:

[ Edited ]
Posted in reply to AravindPalanichamy

Hi,

 

What version of SAS and EMiner are you one?

 

In the SAS note that was referred to, it is explained that the permissions for read meta are being set in the

library manager. The permissions should be set on the FOLDER, not the library in the Lib Manager.

 

Some input, maybe it helps. It works in my environment.

 

Ad Permissions

Before you create a library (and this is true for general library creations), go to the Folders tab in SASMC and create

a folder structure, or, a single folder, as location for the libraries you are going to create, and the tables you are going to register.

 

The creation of a SAS Folder is not only important for the EMiner scenario, but generally for libraries that are being created.
This is important because the folder that's associsated with the library has to have the RM permissions assigned.

An easy way to do that is to grant RM to SASUSERS on this folder.

 

 

Ad Library Creation 

Pre-assigning a library in SASMC:

 

  • During creation of a new library, choose ADVANCED OPTIONS in the Library Properties window (in window for path specifications) and check Library is pre-assigned.
  • If you want to pre-assign an already existing library, right click on the lib in the Library Manager, Options tab, Advanced Options, check Library is pre-assigned.

 

 

 Ad METAAUTORESOURCE

 

EMiner requires metadata libraries to be pre-initialized. Only pre-initialized metadata objects can actually be seen from the EMiner client. In order to pre-initialize a library for EMiner, you have to add the METAAUTORESOURCES option.

 


METAAUTORESOURCES System Option

"Identifies the metadata resources that are assigned when you start the SAS Metadata Server."

http://support.sas.com/documentation/cdl/en/lrmeta/70119/HTML/default/viewer.htm#p1wdznofxy2l9ln17ld...

 

The METAAUTORESOURCES option functions like a telephone operator. When you start EMiner, this option tells the metadata server to start a workspace server, and with that, users have the metadata libraries available in EMiner.

 

In SASMC, go to Application Management

  • Click the SAS Enterprise Miner icon
  • Expand the Projects folder
  • In the Projects folder, right-click the logical workspace server icon (SASApp), and select Properties from the pop-up menu
  • In the Options tab, in the MPCONNECT launch command field, add 

On Windows

SAS -metaautoresources "SASApp" -config "c:\sas_config_dir\lev1\sasapp\sasv9.cfg"

 

On UNIX:

/installdir/…/Lev1/SASApp/sas.sh -metaautoresources "SASApp"

 

Give it a shot, maybe checking this entire set up will help to pin point the issue. Definitely, as Juan mentioned,

check permissions.

 

Resources & Further details:

http://support.sas.com/documentation/cdl/en/emxndg/67980/HTML/default/viewer.htm#p15m68fofeq4imn1jms...

 

http://support.sas.com/documentation/cdl/en/emxndg/67980/HTML/default/viewer.htm#p0vvvenme5cpfkn1pjz...

 

Cheers

Anja 

Ask a Question
Discussion stats
  • 7 replies
  • 252 views
  • 1 like
  • 3 in conversation