Architecting, installing and maintaining your SAS environment

SAS EV MANAGER

Reply
Contributor
Posts: 61

SAS EV MANAGER

Hello,

 

Recently i have enabled SAS EV Manager  and initialized both APM and ACM successfully. Due to multi server deplyment and secured configs agents are not collecting metrics from different servers. Si i have disabled security check in SAS DeploymentAgent config file and restarted.

 

Also i have used a command ./emi_init.sh --resetDB -f which successfully resets the DB. 

 

Now i am facing an issue while running the ./master_apm_etl.sh script and this code is not getting credentials from SAS WIP database.I have attached the log as well. Error showing as getDBMirrorData .sas. error (exited with rc=2). 

 

i believe in PostgreSQL does not have stored userids and passwords and authentications domains. Through deployment Manager i have updated all the evdb and dbmsowner and sasevs@saspw to mid tier. But still no luck ,i am getting same errors.

 

Please let me know where exactly i am missing th elink between Metadata to WIP/Postgresql.

Thanks & Regards,

Sandeep

Trusted Advisor
Posts: 1,414

Re: SAS EV MANAGER

Posted in reply to sandeep_reddy

Hello @sandeep_reddy,

 

I can see several errors previous to that one you are referring to, related to the macros defined on genextractv2.sas

Have you been playing with the standard code? If yes, perhaps it would be a good idea to restore the standard code provided by SAS.

 

 

MLOGIC:  Beginning compilation of GENEXTRACTV2 using the autocall file 
      /sas/config/Lev1/Web/SASEnvironmentManager/emi-framework/SASMacros/genextractv2.sas.
ERROR: There is no matching %DO statement for the %END. This statement will be ignored.

If not, perhaps it would be healthy to contact SAS Technical Support.

 

Kind regards,

Juan

 

Ask a Question
Discussion stats
  • 1 reply
  • 85 views
  • 0 likes
  • 2 in conversation