Architecting, installing and maintaining your SAS environment

SAS EV MANAGER Issue

Accepted Solution Solved
Reply
Contributor
Posts: 61
Accepted Solution

SAS EV MANAGER Issue

Hello All,

 

I recently have enabled SAS EV manager and Installed APM and ACM . When i try to open a nightly report ,ther error is showing as 

 

Missing dataset "WORK.xaudit" . I believe that during stored process execution this output data set is not getting created. 

 

I somehow investigated on this issue and  found that  Artifact.Audit_transactions has Zero Observations.

 

Please help in resolving this issue or some one can help in Understanding of this issue better way.

 

Thanks & Regards,

Sandeep


Accepted Solutions
Solution
‎10-26-2017 10:32 PM
Contributor
Posts: 66

Re: SAS EV MANAGER Issue

Posted in reply to maheshtalla

Hi Sandeep_reddy,

 

Can you please check logCentralise file from ~//Lev1/Web/SASEnvironmentManager/emi-framework/Logs. 

If you see below lines, 

- SAS Deployment Agent security is enabled for server..

- Automatic log copying will be disabled

- Skipping remote log copy for server..

We had similar issue in our environment and below is the suggestion we had from TS.

Problem is that the log_centralize.sh script cannot gather log archives from remote hosts if the SAS Deployment Agent on the remote host is running in secured mode. To collect the logs, you can either use a method such as file mounts or manual transfer, or you can run SAS Deployment Agent in unsecured mode.

 

Please refer below link depending on your maintenance release.

https://support.sas.com/rnd/emi/SASEnvMgr/EVSAF/SAS_Environment_Manager_Service_Architecture_Quickst...

http://support.sas.com/documentation/cdl/en/evug/69029/HTML/default/viewer.htm#n1663ahs2ec37sn1kk180...

 

View solution in original post


All Replies
Trusted Advisor
Posts: 1,424

Re: SAS EV MANAGER Issue

Posted in reply to sandeep_reddy

Hello @sandeep_reddy,

 

EMI framework, including APM, enables several extra auditinrg and reporting features. The way that it works is that SAS 9.4 is based on the WIP platform. The WIP platform, together with nightly processes, collects information from your environment and fills in the WIP database (PostgreSQL). Other set of nightly reports, will fill the EVDM datamart/library (SAS datasets) with information from this WIP database. And the reports will take the information from this datamart (Artifacts library). (Additionally, if you enable the VA feed, EMI will also bring some data from the EVDM datamart into the EVM Autoload in VA).

 

Also, I don't know when you enabled this auditing extra features, but I would hold on for 2 or 3 days to wait for some information to be filled in WIP and let the nightly processes to work on copying data from a data source to the other, so the reports will have something to report.

 

Hence, my recommendations: 1. Wait for a bit. 2. Check the EMI logs to check if the nightly processes are working just fine.

 

For additional information, please read https://support.sas.com/rnd/emi/SASEnvMgr/EVSAF/index.html and http://support.sas.com/resources/papers/proceedings15/SAS1520-2015.pdf 

Contributor
Posts: 66

Re: SAS EV MANAGER Issue

Posted in reply to sandeep_reddy
Hi sandeep,

Can you please let me know the architecture of your environment? Is it multi server deployment? Also please check the logs from ~/Lev1/Web/SASEnvironment/emi-framework/..perticularly logcollect file and see what is exact error there.
Solution
‎10-26-2017 10:32 PM
Contributor
Posts: 66

Re: SAS EV MANAGER Issue

Posted in reply to maheshtalla

Hi Sandeep_reddy,

 

Can you please check logCentralise file from ~//Lev1/Web/SASEnvironmentManager/emi-framework/Logs. 

If you see below lines, 

- SAS Deployment Agent security is enabled for server..

- Automatic log copying will be disabled

- Skipping remote log copy for server..

We had similar issue in our environment and below is the suggestion we had from TS.

Problem is that the log_centralize.sh script cannot gather log archives from remote hosts if the SAS Deployment Agent on the remote host is running in secured mode. To collect the logs, you can either use a method such as file mounts or manual transfer, or you can run SAS Deployment Agent in unsecured mode.

 

Please refer below link depending on your maintenance release.

https://support.sas.com/rnd/emi/SASEnvMgr/EVSAF/SAS_Environment_Manager_Service_Architecture_Quickst...

http://support.sas.com/documentation/cdl/en/evug/69029/HTML/default/viewer.htm#n1663ahs2ec37sn1kk180...

 

Contributor
Posts: 61

Re: SAS EV MANAGER Issue

Posted in reply to maheshtalla
Hi MaheshTalla _reddy ,

I am getting an error as below

WARNING: No login information was available for authdomain SASEnvironmentManagerDatabase.
NOTE: The SAS System stopped processing this step because of errors.
ERROR: (GENEXTRACTV2) The requested table, work.eam_cprop, was NOT created; this may be a result of bad credentials or some other
problem with accessing the back-end database.

When i access SDM to update the password s for sasevdb i am not able to login to SAS WIP database JDBC server using sharedservices account. Please suggest.
Thanks & Regards,
Sandeep
Contributor
Posts: 66

Re: SAS EV MANAGER Issue

Posted in reply to sandeep_reddy

Hi Sandeep_reddy,

 

Not clear, where exactly you are getting those warning and error, Is that when you generate reports?

Looks this issue is different, Not sure which account you are using, may be try with SAS Environment manager service or DB account and see if its works. 

☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 5 replies
  • 216 views
  • 0 likes
  • 3 in conversation