Architecting, installing and maintaining your SAS environment

SAS 9.4 configuration failure at stage 11

Reply
Contributor
Posts: 27

SAS 9.4 configuration failure at stage 11

Good day,

 

I have the Windows Server 2012R2 and I trying to install SAS 9.4 M4(Standalone Installation) and I have a error, when I trying configuration Stage 11: Web Application Server configuration ..

 

The error says, 

 

The following problem was encountered while configuring SAS Web Application Server Node Configuration: Application Server has started, however web applications with the following contexts failed to start. Please refer to Application Server logs for more details.

 

Attached a Print Screen below

 

 

Regards..


MensajeError Stage11.jpg
Contributor
Posts: 66

Re: SAS 9.4 configuration failure at stage 11

Hi David,
Even I had same issue @ step 11 some time back, i'm not sure if that is correct way but it worked for me. Please refer to below link i had provided solution.,
https://communities.sas.com/t5/Administration-and-Deployment/SAS-9-4-configuration-failure-at-stage-...
Contributor
Posts: 27

Re: SAS 9.4 configuration failure at stage 11

Posted in reply to maheshtalla

Thanks @maheshtalla,

 

I have a Doubt, when I see the message of issue, I have to press Yes, No or Retry?

Contributor
Posts: 66

Re: SAS 9.4 configuration failure at stage 11

Hi David,
It depends on what you decide, If you want to continue with further config steps you can press yes/yes to all. It not good to proceed since next steps fails obviously as it has dependencies. Option "No" will not proceed further and it exits. If you press "retry" it will try may be you can try it some times retry should work.

Also there are lot of factors to be consider like pre-req on firewall, ulimit etc as discussed in my thread
Trusted Advisor
Posts: 1,326

Re: SAS 9.4 configuration failure at stage 11

Hello @DavidGQ,

 

I found this before. The problem usually comes when there is a problem of configuration in one of the basic components on SASServer1_1, which basically contains the web components of Web Infrastructure Platform (WIP). Thos problem may come from SASLogin, SASContentServer, WIP Services...

 

I expect that most probably, there migh be something wrong in the pre-requisites, or your response file (configuration), or you missed post-configuration steps from the hotfixes documents , therefore you might need to repeat the installation from scratch or, at least, from the installation of the binaries.

 

I would check your response file (if you have created it, something I always recommend, highly) and your logs, but most importantly, I would open a track with SAS Technical Support. 

New Contributor
Posts: 2

Re: SAS 9.4 configuration failure at stage 11

Posted in reply to JuanS_OCS

Hi All

I have the same problem when configuring SAS 9.4 web server. the install fail in the stage 11 when starting the "SAS Web Application Server Configuration".

I've tried the solution suggested by @maheshtalla but it doesn't work.

I've alreadey open a ticket in SAS Support and no solution until now.

screenshot 0.pngscreenshot 1.png

 

Please find in attachement the log vfabrictcsvr_startMidtierServers.

 

Do you have any idea ? @DavidGQ did you find a solution for your problem ?

 

Thanks

 

SAS Employee
Posts: 284

Re: SAS 9.4 configuration failure at stage 11

@ghalbi,

 

You had a problem with starting SASServer11_1:

 

[appserverTarget] 2017-09-02 21:06:01,451 [main] ERROR com.sas.appserver.vfabrictcsvr.Server - Webapp with

SASModelManagerJavaServices context failed to start

 

I would like to review these files from /sas/sasconf/Lev1/Web/WebAppServer/SASServer11_1/logs

 

  • catalina.out
  • gemfire.log
  • server.log
Contributor
Posts: 27

Re: SAS 9.4 configuration failure at stage 11

Hi @ghalbi, what kind of installation do you have?

 

In my case I had have a Standalone installation, for this problem I was review the all Ports in use with Netstat command and deactivated Ipv6 and then I was restarted de SAS_Server...one for one and Retry the configuration. With that my probleme was solved. 

New Contributor
Posts: 2

Re: SAS 9.4 configuration failure at stage 11

Hello,

 

I succeded to solve the problem and bypass the error in step 12.  Here's what I did:
When configuring Web server and when the stage 12 is running , I have generated manually the scripts for launching the services sas (sas.servers, sas.servers.mid, sas.servers.pre) by launching the script " generate_boot_scripts.sh ".

Step 12 has passed and the installation has ended successfully. I am finalizing the post-installation and it seems to work.

I don't have a logical explanation of this until now.

 

Thanks.

Ask a Question
Discussion stats
  • 8 replies
  • 374 views
  • 0 likes
  • 5 in conversation