Architecting, installing and maintaining your SAS environment

SAS 9.4 M5 installation issue

Accepted Solution Solved
Reply
Occasional Contributor
Posts: 10
Accepted Solution

SAS 9.4 M5 installation issue

Hi All,

 

We have started a fresh planned installation of our SAS 9.4 M5 on multi machine environment,

We have installed metadata 1 & metadata2 (clustered )on different hosts successfully. We are facing issues while installing metadata 3  configuration files on  another host.Below is the error. sas account is already on the current host where installation is being started & the filesystem is shared across all the hosts.Any clues what is causing this issue?

 

 

 

 

validateUserHostAccount:

[propertyfile] Updating property file: /SAS/SASConfig/meta3/Lev1/Logs/Configure/metadatasrvn_config_status.properties

[propertyfile] Updating property file: /SAS/SASConfig/meta3/Lev1/Logs/Configure/metadatasrvn_config_status.properties

     [exec] Current OS is Linux

     [exec] Using input "********"

     [exec] Executing '/SAS/SASHome/SASFoundation/9.4/utilities/bin/sasumgmt' with arguments:

     [exec] '-stdio'

     [exec] '-u'

     [exec] 'sas'

     [exec]

     [exec] The ' characters around the executable and arguments are

     [exec] not part of the command.

     [exec] NOTE: Access denied.

     [exec] Result: 1

  [antcall] Exiting /SAS/SASHome/SASFoundation/9.4/misc/base/sasconf/metadatasrv/config/metadatasrv_config.xml.

 

 


Accepted Solutions
Solution
‎02-20-2018 08:54 AM
SAS Employee
Posts: 61

Re: SAS 9.4 M5 installation issue

During the install of SAS Foundation was pam chosen to be used for user authentication?

If so, is /etc/pam.d/sasauth correctly defined?

You might try use proc permtest to debug the authentication
http://support.sas.com/kb/39/891.html

View solution in original post


All Replies
Frequent Contributor
Posts: 133

Re: SAS 9.4 M5 installation issue

[ Edited ]

I think that the password that the SDW has stored for your SAS user is incorrect, or the account might be locked. Try running this manually on that node after the failure and see what it says:

 

/SAS/SASHome/SASFoundation/9.4/utilities/bin/sasumgmt -stdio -u sas -v

 

Nik

Solution
‎02-20-2018 08:54 AM
SAS Employee
Posts: 61

Re: SAS 9.4 M5 installation issue

During the install of SAS Foundation was pam chosen to be used for user authentication?

If so, is /etc/pam.d/sasauth correctly defined?

You might try use proc permtest to debug the authentication
http://support.sas.com/kb/39/891.html
Occasional Contributor
Posts: 10

Re: SAS 9.4 M5 installation issue

Posted in reply to SimonDawson
Trusted Advisor
Posts: 1,737

Re: SAS 9.4 M5 installation issue

[ Edited ]

Hello @Keerthip,

 

did you have the chance to give a look into @boemskats's and @SimonDawson's great pointers? I think they go in the right direction.

 

Here I would like to drop just a quick addition: after installing the binaries: have you run the Operational Qualification on every metadata node?

https://support.sas.com/documentation/installcenter/en/ikinstqualtoolug/66614/PDF/default/qualificat...

 

I wonder if there are differences on your pre-requisite steps or your installation steps. I would recommend to go through them again, it is normally the case.

☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 4 replies
  • 275 views
  • 4 likes
  • 4 in conversation