Architecting, installing and maintaining your SAS environment

SAS(9.4 M5) Environment Manager's Service Architecture Framework - Error

Reply
Highlighted
Occasional Contributor
Posts: 6

SAS(9.4 M5) Environment Manager's Service Architecture Framework - Error

Hi ,

 

I am trying to Initializing SAS Environment Manager Service Architecture Framework.

 

Though I didnt receive any errors when running "/sascommon/SAS/SASConfig/grid1/Lev1/Web/SASEnvironmentManager/emi-framework/bin/validate.sh --level 2", I got the following error when ran the below command:"./emi_init.sh -i"

 

 

========================================================================================

[sas@sesklsasgrndev01 bin]$ ./emi_init.sh -i
Service Architecture Initialization Utility - Wed May 16 18:52:24 CEST 2018
Validating environment...
Validating external connections...
Starting initialization...
Importing SPK package(s) to SAS Metadata server...
Unable to set the URL of the Stored Process web application (RC=253)
Service Architecture HTTP Platform Service Utility - Wed May 16 18:53:40 CEST 2018
Command failed with RC 253
There was a problem creating HTTP checks (rc [2]). Check the log file.

================================================================================

 

Please help me to resolve the issue.

 

Thanks

Menaka B

 

SAS Employee
Posts: 36

Re: SAS(9.4 M5) Environment Manager's Service Architecture Framework - Error

Hi. Please see if this SAS Note helps you, http://support.sas.com/kb/61/845.html. If it does not help you resolve your issue, I'd suggest opening a ticket with SAS Technical Support. 

Occasional Contributor
Posts: 6

Re: SAS(9.4 M5) Environment Manager's Service Architecture Framework - Error

Hi,

 

Thankyou for your reply.

 

Following the hotfix installation(C1N001), I can get past through the step "./emi_init.sh -i" without any errors.

 

But now receiving a different error when Initializing the APM. Attached the apminit log (Error: Error: Could not find or load main class groovy.lang.GroovyShell) for reference.

 

[sas@sesklsasgrndev01 bin]$ ./apm_init.sh

Service Architecture APM Initialization - Fri May 18 15:17:34 CEST 2018

Validating environment...

Initializing APM...

        Initializing sesklsasgrndev01.emea.astrazeneca.net...

                Initialize failed for sesklsasgrndev01.emea.astrazeneca.net

        Initializing sesklsasmetdev01.emea.astrazeneca.net...

                Initialize failed for sesklsasmetdev01.emea.astrazeneca.net

        Initializing sesklsasmiddev01.emea.astrazeneca.net...

                Initialize failed for sesklsasmiddev01.emea.astrazeneca.net

        Initializing sesklsasmiddev02.emea.astrazeneca.net...

                Initialize failed for sesklsasmiddev02.emea.astrazeneca.net

        Initializing sesksasgcdev01.emea.astrazeneca.net...

                Initialize failed for sesksasgcdev01.emea.astrazeneca.net

APM was initialized with [5] warning(s). Check apmInit_20180518_151733.log for details

 

Any idea on how to resolve this.

 

Thanks

Menaka

SAS Employee
Posts: 36

Re: SAS(9.4 M5) Environment Manager's Service Architecture Framework - Error

Did you perform the post installation steps in the hot fix? If so, what goovy do you have listed when you run ls -la on Lev1/Web/Scripts/AppServer/lib? 

Ask a Question
Discussion stats
  • 3 replies
  • 111 views
  • 0 likes
  • 2 in conversation