Architecting, installing and maintaining your SAS environment

SAS 9.4 M3 Environment Manager 2.5 Administration Tab is not working

Reply
Occasional Contributor
Posts: 10

SAS 9.4 M3 Environment Manager 2.5 Administration Tab is not working

Hi Experts,

 

We have a newly installed SAS 9.4 M3 setup on linux box. Environment Manager is working but when I click on Administration Tab, it opens up in a new window but then page fails to load with the following errors:

 

Uncaught Error: failed to load 'admappfldmod/commons/library.js' from https://dummyurl/SASEnvironmentMgrMidTier/js/shcb1452691786549/admappfldmod/commons/library.js 

404 - Not Found

line: 134

col: 31442

Error: failed to load 'admappfldmod/commons/library.js' from  

 

and following errors in the Lev1/Web/Logs/SASServer1_1/SASEnvironmentMgrMidTier2.5.log file

 

2016-01-13 14:29:46,544 [tomcat-http--246] ERROR [ST-20534-YTf49JJ32g6Zywp4Dm5T-cassasadm] com.sas.commons.html.util.CommonsUtil - Could not obtain build time stamp for this product
java.lang.IllegalStateException: Unable to find resource: buildinfo.xml, in class loader: WebappClassLoader
context: /SASEnvironmentMgrMidTier
delegate: false
repositories:
/WEB-INF/classes/
----------> Parent Classloader:
org.apache.catalina.loader.StandardClassLoader@52a00770

at com.sas.framework.commons.util.BuildInfo.<init>(BuildInfo.java:70)
at com.sas.framework.commons.util.BuildInfo.<init>(BuildInfo.java:58)
at com.sas.framework.commons.util.BuildInfo.<init>(BuildInfo.java:50)

 

Any idea why I am gettign this error? My installation was successfully without any errors.

 

Regards,

 

Shatrughan

Super User
Posts: 3,102

Re: SAS 9.4 M3 Environment Manager 2.5 Administration Tab is not working

If you haven't already done so I suggest you track this problem to SAS Tech Support as they are in the best position to help you with this type of problem.

 

Environment Manager has only been available since SAS 9.4 so it is new to many users and is tricky to get running smoothly.

Contributor
Posts: 30

Re: SAS 9.4 M3 Environment Manager 2.5 Administration Tab is not working

@shatrughan have you managed to get the issue sorted in Environment Manager - I'm hitting the same thing.

Regular Contributor
Posts: 170

Re: SAS 9.4 M3 Environment Manager 2.5 Administration Tab is not working

If you try to pull up the application in a separate browser/tab does it give you the same error (that is, entering the URL manually into the browser/tab instead of clicking on the tab in Environment Manager)? I have seen various issues in my installation when attempting to access from the tab within Environment Manager, but if I go to the link directly it works.
SAS Employee
Posts: 5

Re: SAS 9.4 M3 Environment Manager 2.5 Administration Tab is not working

What browser are you using? For Lunux, Google Chrome 33 or higher should be used. For anyone using IE 11, make sure Compatibility Mode is turned OFF.

Contributor
Posts: 30

Re: SAS 9.4 M3 Environment Manager 2.5 Administration Tab is not working

I've tried Chrome and FireFox, but sitll the same issue.

 

Based on the the Grid Manager plugin, it's states 'Platform Web Services appears to be down' , but JVM 14 where the plugin is deployed is currently up and running.

 

I also tried opening the app in a seperate URL, but it's the same issue - though, it should work from EVM.

 

I raised in with Support, but nothing yet.

Trusted Advisor
Posts: 1,141

Re: SAS 9.4 M3 Environment Manager 2.5 Administration Tab is not working

Hi,

 

may you could check if the internal/external urls in DP-Environment manager and Environment Manager Mid tier are set up properly to HTTPS?

 

I heard from a colleague a similar issue, and it could be related to something related to a missing configuration.


Anyway, I would recommend you to contact SAS Technical Support for this type of problem.

Regular Contributor
Posts: 170

Re: SAS 9.4 M3 Environment Manager 2.5 Administration Tab is not working

Did you do an upgrade-in-place from M2 to M3 or did you install?
Contributor
Posts: 30

Re: SAS 9.4 M3 Environment Manager 2.5 Administration Tab is not working

It was a fresh install 9.4M3.

 

Managed to get it resolved, make sure all URL's are matching in SMC, setenv.sh and in Environment Manager configuration properties.

Trusted Advisor
Posts: 1,141

Re: SAS 9.4 M3 Environment Manager 2.5 Administration Tab is not working

Great! Good job figuring out the solution!

 

I would select your own answer as solution for your question if I could Smiley Happy

Ask a Question
Discussion stats
  • 9 replies
  • 999 views
  • 2 likes
  • 6 in conversation