Architecting, installing and maintaining your SAS environment

SAS 9.2 and Red Hat Linux 7

Accepted Solution Solved
Reply
New Contributor
Posts: 4
Accepted Solution

SAS 9.2 and Red Hat Linux 7

Hi!

We faced with RHEL 6 bag when SMB v2 doesn't work on this platform. The option to enable SMB v1 is also may be applied but as last solution(bacause of Security policy). So we also consider an option of deployment SAS 9,2 on the RHEL 7 and migrate the data. So maybe someone had experience with this deal? Can anybody tell does the SAS 9.2 work on Red Hat Enterprise Linux 7 ?

 


Accepted Solutions
Solution
2 weeks ago
Trusted Advisor
Posts: 1,141

Re: SAS 9.2 and Red Hat Linux 7

Hello @ur4eg,

 

RHEL 7 is not supported on SAS 9.2. The reason is that SAS 9.2 is not in maintenance mode since several years ago, therefore no adaptation of the code for RHEL 6 or 7. Therefore, scome code might not link to the appropiate so libraries, as good example.

 

This does not mean that you cannot manage to make it work, necessarily. But the main question is: are you or your company willing to spend some precious time, knowing that you will be on your own, with posibility that if you have troubles (during installation or during maintenance) perhaps you won't get any official support?

 

As suggested by @KurtBremser, I would either stay behind the recomendations of RHEL 4 or 5 if I use SAS 9,2, or I would migrate to SAS 9.4 and in this latter case I can get full support and software updates from SAS and from RedHat 6 or 7. From an architecture point of view I would go to the second option, but I also understand that, budget-wise, sometimes the choice is to wait to the very last moment or until it is not strictly required.

 

Hope it helps.

 

Kind regards,

Juan

View solution in original post


All Replies
Super User
Posts: 6,932

Re: SAS 9.2 and Red Hat Linux 7

[ Edited ]

Since the requirements page for 9.2 names RHEL 4 & 5, I seriously doubt you could install and run it successfully on 7. Use the opportunity to also migrate to 9.4.

Having done that migration (on AIX) in the recent past, I can only say it's worth the effort.

---------------------------------------------------------------------------------------------
Maxims of Maximally Efficient SAS Programmers
New Contributor
Posts: 4

Re: SAS 9.2 and Red Hat Linux 7

@

The last requirements I've found that SAS is supported by RHEL 4, 5, and 6.

http://support.sas.com/documentation/installcenter/en/ikfdtnlaxsr/62147/PDF/default/sreq.pdf

That's all. All other is about RHEL 7 and SAS 9.4.

And I don't clear understand could I use SAS 9.4 when we bought license for SAS 9.2 ?

Super User
Posts: 6,932

Re: SAS 9.2 and Red Hat Linux 7


ur4eg wrote:

And I don't clear understand could I use SAS 9.4 when we bought license for SAS 9.2 ?


A valid SAS license will always include upgrading to the current version. Just get in touch with your local SAS representative, and they will provide you with a 9.4 installation package and a license file for it.

9.4 has many benefits, among them SAS Studio, easier access to the XLSX format, and many others.

---------------------------------------------------------------------------------------------
Maxims of Maximally Efficient SAS Programmers
Solution
2 weeks ago
Trusted Advisor
Posts: 1,141

Re: SAS 9.2 and Red Hat Linux 7

Hello @ur4eg,

 

RHEL 7 is not supported on SAS 9.2. The reason is that SAS 9.2 is not in maintenance mode since several years ago, therefore no adaptation of the code for RHEL 6 or 7. Therefore, scome code might not link to the appropiate so libraries, as good example.

 

This does not mean that you cannot manage to make it work, necessarily. But the main question is: are you or your company willing to spend some precious time, knowing that you will be on your own, with posibility that if you have troubles (during installation or during maintenance) perhaps you won't get any official support?

 

As suggested by @KurtBremser, I would either stay behind the recomendations of RHEL 4 or 5 if I use SAS 9,2, or I would migrate to SAS 9.4 and in this latter case I can get full support and software updates from SAS and from RedHat 6 or 7. From an architecture point of view I would go to the second option, but I also understand that, budget-wise, sometimes the choice is to wait to the very last moment or until it is not strictly required.

 

Hope it helps.

 

Kind regards,

Juan

New Contributor
Posts: 4

Re: SAS 9.2 and Red Hat Linux 7

Got confirmation from SAS support: There is no support for 9.2 on RHEL 7.
Thank you all!
☑ This topic is SOLVED.

Need further help from the community? Please ask a new question.

Discussion stats
  • 5 replies
  • 196 views
  • 4 likes
  • 3 in conversation