Architecting, installing and maintaining your SAS environment

Running ExportPackage (and ImportPackage) headless

Accepted Solution Solved
Reply
Super Contributor
Posts: 251
Accepted Solution

Running ExportPackage (and ImportPackage) headless

I'm in the process of populating the DR box with metadata, and I've got the exporting, secure copy and importing all running tickety-boo. I started off using the wizard, then put the command it issued into a shell script and let cron take care of it. After I set the DISPLAY variable to my Unix session's localhost:12.0, it worked fine.

 

But when I left it running over the weekend, it failed: "java.lang.InternalError: Can't connect to X11 winder server using 'localhost:12.0' as the value of the DISPLAY variable."

 

I know there's a -disableX11 option in ImportPackage (which amusingly is described as being disabled by default: is it disabled or not?!), but that's not available in the version we're running.

 

I've tried with other options I've searched for (variously localhost:0.0, :0.0, localhost:13.0), but really I'm fumbling in the dark.

 

Does anyone know what I should set it to? why is the Unix session's value different to submitted-at-4am's requirement? why should they differ?

 

Laurie


Accepted Solutions
Solution
‎07-19-2016 04:20 PM
Frequent Contributor
Posts: 117

Re: Running ExportPackage (and ImportPackage) headless

I'm afraid the documentation quoted below might be misleading. 

 

If the DISPLAY variable is used like a mere placeholder then the import/export tool won't work since the underlying java session will look for an X11 session already running and pointing to some real adress/socket stored with the DISPLAY value.

 

It will work with the DISPLAY variable only if there is some X11 terminal set up and listening on that value, which amounts to some interactive session requirement : back to square 1 !

 

Unless you can't upgrade to 9.4TS1M3 then Xvfb or anything like it will be needed. Please, don't hesitate to confirm with SAS Technical Support. I might be wrong.

 

FYI, I've tested these tools in batch modes with SAS 9.2/9.3 on RHEL 5/6 with and without Xvfb.


LaurieF wrote:

Yes, thank you, I saw that. But it doesn't answer my question; nor am I in a position to install more software on this machine.

 

The documentation for Intelligence Platform batch tools implies that there is a setting for DISPLAY which will do what -disableX11 does in the third maintenance release. If I could work out why it works when I submit the ImportPackage command manually, but not when it's submitted by cron, then I might be closer to a solution.


 

 

Set the DISPLAY Variable (UNIX Only)

If you are using the batch import or export tool on a UNIX machine, make sure that the DISPLAY variable has been set on the machine. To set the variable, enter a command such as the following:
export DISPLAY=machine-name
Tip
You can use the -disableX11 option to run the batch import or export tool on UNIX without setting the DISPLAY variable. This option is available with the third maintenance release for SAS 9.4.
 

https://support.sas.com/documentation/cdl/en/bisag/68240/HTML/default/viewer.htm#n0861tmrlv3nsen164w...

View solution in original post


All Replies
Frequent Contributor
Posts: 117

Re: Running ExportPackage (and ImportPackage) headless

See this previous discussion related to your question

 

https://communities.sas.com/t5/Administration-and-Deployment/Has-anyone-automated-a-Metadata-sync-pr...

 

package Xvfb would be required.

 

Super Contributor
Posts: 251

Re: Running ExportPackage (and ImportPackage) headless

Yes, thank you, I saw that. But it doesn't answer my question; nor am I in a position to install more software on this machine.

 

The documentation for Intelligence Platform batch tools implies that there is a setting for DISPLAY which will do what -disableX11 does in the third maintenance release. If I could work out why it works when I submit the ImportPackage command manually, but not when it's submitted by cron, then I might be closer to a solution.

Solution
‎07-19-2016 04:20 PM
Frequent Contributor
Posts: 117

Re: Running ExportPackage (and ImportPackage) headless

I'm afraid the documentation quoted below might be misleading. 

 

If the DISPLAY variable is used like a mere placeholder then the import/export tool won't work since the underlying java session will look for an X11 session already running and pointing to some real adress/socket stored with the DISPLAY value.

 

It will work with the DISPLAY variable only if there is some X11 terminal set up and listening on that value, which amounts to some interactive session requirement : back to square 1 !

 

Unless you can't upgrade to 9.4TS1M3 then Xvfb or anything like it will be needed. Please, don't hesitate to confirm with SAS Technical Support. I might be wrong.

 

FYI, I've tested these tools in batch modes with SAS 9.2/9.3 on RHEL 5/6 with and without Xvfb.


LaurieF wrote:

Yes, thank you, I saw that. But it doesn't answer my question; nor am I in a position to install more software on this machine.

 

The documentation for Intelligence Platform batch tools implies that there is a setting for DISPLAY which will do what -disableX11 does in the third maintenance release. If I could work out why it works when I submit the ImportPackage command manually, but not when it's submitted by cron, then I might be closer to a solution.


 

 

Set the DISPLAY Variable (UNIX Only)

If you are using the batch import or export tool on a UNIX machine, make sure that the DISPLAY variable has been set on the machine. To set the variable, enter a command such as the following:
export DISPLAY=machine-name
Tip
You can use the -disableX11 option to run the batch import or export tool on UNIX without setting the DISPLAY variable. This option is available with the third maintenance release for SAS 9.4.
 

https://support.sas.com/documentation/cdl/en/bisag/68240/HTML/default/viewer.htm#n0861tmrlv3nsen164w...

Super Contributor
Posts: 251

Re: Running ExportPackage (and ImportPackage) headless

<nods> I had a chat with a SAS Institute chappy yesterday who pretty much said exactly what you have just put forward. Thank you very much. He apologised for the misdirection in the documentation.

 

I left my X-terminal sessions on both the export and import machines running last night, and they both worked fine, because they both thought they had something to send stuff too, even though neither session ultimately wanted to. Heavy sigh.

 

I'm going to chat to the Unix sysadmin today to see what he suggests. They might have a dummy DISPLAY value to use (the SAS guy said it was possible, but unlikely), but I will also ask about Xvfb.

 

Laurie

Frequent Contributor
Posts: 117

Re: Running ExportPackage (and ImportPackage) headless

You're welcome. Nice workaround : an SSH +X11 session left opened can do the trick Smiley Wink .
☑ This topic is SOLVED.

Need further help from the community? Please ask a new question.

Discussion stats
  • 5 replies
  • 510 views
  • 0 likes
  • 2 in conversation