Architecting, installing and maintaining your SAS environment

Property 'serviceUrl' is required - how do I fix this.

Accepted Solution Solved
Reply
Contributor
Posts: 67
Accepted Solution

Property 'serviceUrl' is required - how do I fix this.

From within Management Console, I am attemping to export a report.  I keep getting an error "Property 'serviceUrl' is required".  I have checked my ServiceUrl.Allowed setting and it it set per the documentation.  What am I missing?  If I right click on the report (from within Management Console) and click on the Content tab, I see this same error listed here.

 

Thanks,

Ricky


Accepted Solutions
Solution
‎02-11-2017 09:06 PM
SAS Super FREQ
Posts: 291

Re: Property 'serviceUrl' is required - how do I fix this.

 

Hi,

 

pls provide us with the following info:

- SAS version

- OS

 

Reasons for this problem are usually because the ...url.allowed... is not set, but you said that you checked and that

it is there.

Another reason could be a problem with certificates used.

In such cases, the problem is taken care off by copying the SSL files CACERTS and JSSEACERTS from middlte tier to client.

 

Go to

<SASHOME>/SASPrivateJavaRuntimeEnvironment/9.4/jre/lib/security

and copy the SSL files “cacerts” and “jssecacerts”:

 

Then copy the middle-tier files to the following path on the machine SASMC is started from:
C:\Program Files\SASHome\SASPrivateRuntimeEnvironment\9.4\jre\lib\security

(all depending on the OS)

 

What reports are you trying to export? VA. WRS, etc?

 

If you are on SAS 9.4 and Environment Manager is installed, I'd be curious to know if you can start this

web app.

 

Are there any problems starting or logging in to any SAS web applications or have there been also

any problems with non SAS web apps?

 

Thanks

Anja

View solution in original post


All Replies
Solution
‎02-11-2017 09:06 PM
SAS Super FREQ
Posts: 291

Re: Property 'serviceUrl' is required - how do I fix this.

 

Hi,

 

pls provide us with the following info:

- SAS version

- OS

 

Reasons for this problem are usually because the ...url.allowed... is not set, but you said that you checked and that

it is there.

Another reason could be a problem with certificates used.

In such cases, the problem is taken care off by copying the SSL files CACERTS and JSSEACERTS from middlte tier to client.

 

Go to

<SASHOME>/SASPrivateJavaRuntimeEnvironment/9.4/jre/lib/security

and copy the SSL files “cacerts” and “jssecacerts”:

 

Then copy the middle-tier files to the following path on the machine SASMC is started from:
C:\Program Files\SASHome\SASPrivateRuntimeEnvironment\9.4\jre\lib\security

(all depending on the OS)

 

What reports are you trying to export? VA. WRS, etc?

 

If you are on SAS 9.4 and Environment Manager is installed, I'd be curious to know if you can start this

web app.

 

Are there any problems starting or logging in to any SAS web applications or have there been also

any problems with non SAS web apps?

 

Thanks

Anja

Contributor
Posts: 67

Re: Property 'serviceUrl' is required - how do I fix this.

Anja,

 

Thank you for your reply.  Copying the files to the specified location fixed my issue.  The odd part now is that we have two environments (DEV and PROD).  Dev was working fine, but PROD was having this issue.  Now that I made the below change, I went back and checked DEV...and to my surprise, it seems to still be working too.

 

Thanks again,

Ricky 

SAS Super FREQ
Posts: 291

Re: Property 'serviceUrl' is required - how do I fix this.

Hi Ricky,

This is great! :-)

 

Best

Anja

☑ This topic is SOLVED.

Need further help from the community? Please ask a new question.

Discussion stats
  • 3 replies
  • 258 views
  • 0 likes
  • 2 in conversation