Architecting, installing and maintaining your SAS environment

No executable files in !SASROOT (SAS 9.4 Foundation in Oracle Linux 6.6)

Accepted Solution Solved
Reply
New Contributor
Posts: 3
Accepted Solution

No executable files in !SASROOT (SAS 9.4 Foundation in Oracle Linux 6.6)

Dear SAS community,

I have recently tried to install SAS9.4 in Oracle Linux 6.6 using campus SAS9.4 iso. But I am facing this problem: NO executable files in !SASROOT directory. There is NO bin under !SASROOT.

I also looked under !SASROOT/SASFoundation/9.4, below are the folders: build  installs  misc  sasexe  utilities. Again no EXECUTABLE.

For my first attempt, I tried installing on Centos 7. And I was not able to find the executable files. After consulting with campus technicians, I have been told that Centos IS not supported BY SAS 9.4.

So I switched to Oracle Linux 6.6 which is an official support from SAS 9.4. Same problem occurred.

BTW, I installed SAS as a regular user not ROOT.

Any help or suggestion will be highly appreciated.

Many thanks,

Yin


Accepted Solutions
Solution
‎06-11-2015 10:28 AM
SAS Employee
Posts: 33

Re: No executable files in !SASROOT (SAS 9.4 Foundation in Oracle Linux 6.6)

Hi Yin. Yes you are correct that Oracle Linux 6 is supported. A full list can be found here, SAS Supported Operating Systems. If there were an issue specific to Oracle Linux 6, it would not be one where the OS is not supported, but rather one where the order you are trying to use was created for a different Platform. This means the SAS executable for Linux would not be in the order and therefore would not be installed.

Thanks!


View solution in original post


All Replies
SAS Employee
Posts: 33

Re: No executable files in !SASROOT (SAS 9.4 Foundation in Oracle Linux 6.6)

Hi Yin.

The problem you appear to be experiencing is often caused by the order being used not being appropriate for the operating system on which you are trying to install. If you open a track with SAS Technical Support and provide the order number they can look it up in their system and see where the mismatch might be occurring or offer debugging steps. Note: You should not provide your order information here on a public site.

A few things you can do on your own that will help them... First I'm assuming you are installing the software from a depot or depot placed on a DVD. If you are trying to install directly from the depot on a DVD, since this is Linux, you might try using the Manage Depots option and first copy the depot to the Linux system. From there you can run a utility that is under the depot's utility directory called SASDepotCheck.sh. This utility will tell you if anything is missing from the depot you have. I really wouldn't expect this to produce any issues since only "executable" contents under !SASROOT appear to be affected, but it is still worth knowing about and doing. When you go through the SAS Deployment Wizard screens, if you are choosing a Planned Deployment when you get to the screens showing what will be installed, anything you see in BOLD are items found to be in the order, but not able to be installed (usually due to an OS mismatch). If you see SAS Foundation in that list then that would indicate you have the order/OS mismatch I mentioned before. If that is the case then you will want to talk to your IT folks there at the university and seek a new order from them. Troubleshooting this beyond these typical issues is best performed by SAS Technical Support.  

New Contributor
Posts: 3

Re: No executable files in !SASROOT (SAS 9.4 Foundation in Oracle Linux 6.6)

Thanks for your prompt reply,

According to SAS documentation, Oracle linux 6 is supported.

As for the depotchecker.sh, yes I am running it now. Hopefully it will provide some useful information.

Yin

Solution
‎06-11-2015 10:28 AM
SAS Employee
Posts: 33

Re: No executable files in !SASROOT (SAS 9.4 Foundation in Oracle Linux 6.6)

Hi Yin. Yes you are correct that Oracle Linux 6 is supported. A full list can be found here, SAS Supported Operating Systems. If there were an issue specific to Oracle Linux 6, it would not be one where the OS is not supported, but rather one where the order you are trying to use was created for a different Platform. This means the SAS executable for Linux would not be in the order and therefore would not be installed.

Thanks!


New Contributor
Posts: 3

Re: No executable files in !SASROOT (SAS 9.4 Foundation in Oracle Linux 6.6)

It looks like my SAS order is for windows.

Will post when I get the Linux version.

Thanks,

Yin

☑ This topic is SOLVED.

Need further help from the community? Please ask a new question.

Discussion stats
  • 4 replies
  • 386 views
  • 0 likes
  • 2 in conversation