Architecting, installing and maintaining your SAS environment

Need SAS Administrators group for VA to work

Accepted Solution Solved
Reply
Regular Contributor
Posts: 211
Accepted Solution

Need SAS Administrators group for VA to work

Hi team,

 

New install of VA on Windows x64.

 

I have three issues:

1.) The user running the autoload doesn't have permission to update the metadata folder with the table. However, the user has RM, WM, WMM, etc permissions on the target folder.

2.) When logging onto VA Hub, the user gets an error about favourites not being retrieved from the Metadata. Turns out, the user can't create the Visual Analytics sub-folder under his home folder. Again, all the required permissions seem to be there.

3.) The Hub page is blank when logging on.

 

Now, when I add the user to the SAS Administrators group, all the above issues go aways instantly and the solutions works perfectly. I cannot think this is the correct way since we cannot make the end users all SAS admins.

 

Please educate me what I'm missing here ?

 

Thanks,


Accepted Solutions
Solution
‎09-19-2017 12:18 AM
Trusted Advisor
Posts: 1,427

Re: Need SAS Administrators group for VA to work

Hi @nhvdwalt,

 

I am wondering the exact actions you took regarding security administration (metadata permissions and roles).

Indeed, you won't need to add every user as administrator, no need.

 

I believe the following links will help you:

 

Adding Users - https://support.sas.com/documentation/cdl/en/vaag/69958/HTML/default/viewer.htm#n1qzydpsie8xr0n0zddg...

 

Orientation - https://support.sas.com/documentation/cdl/en/vaag/69958/HTML/default/viewer.htm#p03hs3j96lp4nyn1j2br...

 

Permissions - https://support.sas.com/documentation/cdl/en/vaag/69958/HTML/default/viewer.htm#n1r98i0vpddhgnn1mie6...

 

Specially this bit:

 

On the Groups and Roles tab, add direct memberships for the new user:

  • If the user does not perform administrative tasks, move the Visual Analytics Users group to the Member of list.
    user group
  • If the user performs administrative tasks, move one or more of the following groups to the Member of list:
    Visual Analytics Data Administrators
    (for suite-level administrative tasks)
    Visual Data Builder Administrators
    (for data preparation tasks)
    SAS Administrators
    (for platform-level administrative tasks)
    Tip
    Unless you know you want to create a limited administrator, move all three groups to the Member of list.
    admin groups

View solution in original post


All Replies
Solution
‎09-19-2017 12:18 AM
Trusted Advisor
Posts: 1,427

Re: Need SAS Administrators group for VA to work

Hi @nhvdwalt,

 

I am wondering the exact actions you took regarding security administration (metadata permissions and roles).

Indeed, you won't need to add every user as administrator, no need.

 

I believe the following links will help you:

 

Adding Users - https://support.sas.com/documentation/cdl/en/vaag/69958/HTML/default/viewer.htm#n1qzydpsie8xr0n0zddg...

 

Orientation - https://support.sas.com/documentation/cdl/en/vaag/69958/HTML/default/viewer.htm#p03hs3j96lp4nyn1j2br...

 

Permissions - https://support.sas.com/documentation/cdl/en/vaag/69958/HTML/default/viewer.htm#n1r98i0vpddhgnn1mie6...

 

Specially this bit:

 

On the Groups and Roles tab, add direct memberships for the new user:

  • If the user does not perform administrative tasks, move the Visual Analytics Users group to the Member of list.
    user group
  • If the user performs administrative tasks, move one or more of the following groups to the Member of list:
    Visual Analytics Data Administrators
    (for suite-level administrative tasks)
    Visual Data Builder Administrators
    (for data preparation tasks)
    SAS Administrators
    (for platform-level administrative tasks)
    Tip
    Unless you know you want to create a limited administrator, move all three groups to the Member of list.
    admin groups
Regular Contributor
Posts: 211

Re: Need SAS Administrators group for VA to work

Posted in reply to JuanS_OCS

Great, thanks @JuanS_OCS. It seems like the inclusion into the Visual Analytics User group did the trick.

 

Many thanks,

☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 2 replies
  • 183 views
  • 0 likes
  • 2 in conversation