Architecting, installing and maintaining your SAS environment

Need SAS 9.4/FM 5.5 Struts Version?

Reply
Occasional Learner
Posts: 1

Need SAS 9.4/FM 5.5 Struts Version?

[ Edited ]

Hello!

 

We've recently deployed SAS 9.4 with the Financial Management components (version 5.5).   We are at TS1M5 as of today and looking to see what version of Apache Struts we have.  

 

I've followed some google-foo and the struts-core.jar files shows something of a 1.x specification but I feel that's awfully low.   This is a security concern of ours (sound familiar?) so we're looking for something that's identifiable at this maintenance level.

 

Again - just looking for the struts version that SAS is at with 9.4 TS1M5 by default.  We have very little customization.   Please also know I'm not a SAS person but an infrastructure person helping search this out.

 

For further clarity, we use the VA Hub to launch documentation within Excel and use the add-in to upload. We also use FM Studio, Data Integration, and a few other things (The Financial Management web portal too).   I believe these all uses the Apache services their core.

 

Thanks in advance,

Adam

 

Edit:  Further clarification of what we have.

Trusted Advisor
Posts: 1,746

Re: Need SAS 9.4/FM 5.5 Struts Version?

Hello @AdamBre,

 

I think your question should be answered by a SAS developer, hence, SAS Technical Support should be, probably, your best way to address it.

 

As previous Java developer (not at SAS Smiley Happy ), I can tell you that you can always search for the struts-config.xml in your web application and check the version actually used by the application. Or in the MANIFEST file, inside the META-INF folder.

 

An example:

https://stackoverflow.com/questions/4021995/how-to-find-the-struts-version-being-used-in-a-project

SAS Employee
Posts: 512

Re: Need SAS 9.4/FM 5.5 Struts Version?

[ Edited ]

@AdamBre,

 

SAS is using the custom version of Apache Struts.

Trusted Advisor
Posts: 1,746

Re: Need SAS 9.4/FM 5.5 Struts Version?

@alexal,

 

I feel curious, do you have details about custom version of Strut 2? What aspects have been customized?

SAS Employee
Posts: 512

Re: Need SAS 9.4/FM 5.5 Struts Version?

Posted in reply to JuanS_OCS

@JuanS_OCS,

 

I do not have such information.

SAS Employee
Posts: 512

Re: Need SAS 9.4/FM 5.5 Struts Version?

Posted in reply to JuanS_OCS

@JuanS_OCS,

 

I've corrected my original statement about the version number.

Ask a Question
Discussion stats
  • 5 replies
  • 240 views
  • 1 like
  • 3 in conversation