Architecting, installing and maintaining your SAS environment

Model Manager issue, can't create new models

Accepted Solution Solved
Reply
Contributor
Posts: 23
Accepted Solution

Model Manager issue, can't create new models

All started after I changed the password of all users shown in deployment manager.

 

Creating Model using CI Studio is throwing error "unable to feth model details from mdel manager rest web service"

 

Model Manager 13.1 log says

 

mm log

 

reverted back the password for sas trust, still same issue.

 

Any help would be great.


Accepted Solutions
Solution
‎05-10-2016 02:39 PM
Contributor
Posts: 23

Re: Model Manager issue, can't create new models

Posted in reply to rajeevk241

Juan,

 

So what has happened here is the deployment manager didn't do its job properly.

 

Under SAS MC -> SAS Foundation Manager-> Model Manager 13.1 -> Core -> User Services-> Config tab -> config button -> 

 

the new password for sas trust was no updated. I updated manually.

 

same way in remote services and CI 6.4

 

and this fixed it.

View solution in original post


All Replies
Trusted Advisor
Posts: 1,312

Re: Model Manager issue, can't create new models

Posted in reply to rajeevk241

Hi,

 

Can you log in with sastrust@saspw in the SAS Management Console with the last changed password? I woukd check if the account is not locked, and if it is, you should unlock it with an unrestricted user.

 

 

Contributor
Posts: 23

Re: Model Manager issue, can't create new models

Posted in reply to JuanS_OCS

Hello Juan,

 

Thanks for responding.

 

new password works perfect for trust avvount. It is not locked.

 

 

Trusted Advisor
Posts: 1,312

Re: Model Manager issue, can't create new models

Posted in reply to rajeevk241

Great, good news. Can you see any message or error on your metadata server ?

 

I personalky would start by aligning with your SAS technical support. It is possible that one configuration file or metadata item did not updated the new password right.

 

In the meantime, to extend logs to a DEBUG level seems to be a good approach to get additional info.

Solution
‎05-10-2016 02:39 PM
Contributor
Posts: 23

Re: Model Manager issue, can't create new models

Posted in reply to rajeevk241

Juan,

 

So what has happened here is the deployment manager didn't do its job properly.

 

Under SAS MC -> SAS Foundation Manager-> Model Manager 13.1 -> Core -> User Services-> Config tab -> config button -> 

 

the new password for sas trust was no updated. I updated manually.

 

same way in remote services and CI 6.4

 

and this fixed it.

Trusted Advisor
Posts: 1,312

Re: Model Manager issue, can't create new models

Posted in reply to rajeevk241

Hi @rajeevk241, thanks a lot for your feedback, and really great that you found out Smiley Wink

☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 5 replies
  • 311 views
  • 1 like
  • 2 in conversation