Architecting, installing and maintaining your SAS environment

Memcache on Windows 7 with UAC

Reply
Frequent Contributor
Posts: 129

Memcache on Windows 7 with UAC

Is it possible to use the SAS 9.3 memcache option on Windows 7 (64bit) without fully disabiling user access control (UAC)? 

Occasional Contributor
Posts: 17

Memcache on Windows 7 with UAC

Here is a bit from a link I found on SAS's website:   http://support.sas.com/documentation/cdl/en/hostwin/63285/HTML/default/viewer.htm#winperform.htm

Specifying the MEMLIB and MEMCACHE Options in 64-Bit Windows Environments

Sixty-four bit processing in Windows operating environments uses 16 terabytes (TB) of virtual address space, so in these environments, extended memory is not needed. SAS uses the conventional memory that is available to support the MEMLIB and MEMCACHE options.

CAUTION:
It is possible to exhaust system memory, and thus cause system failure.

You can use the MEMMAXSZ option to limit the amount of system memory that SAS allocates for the MEMLIB and MEMCACHE options.  [cautionend]

To use the MEMLIB and MEMCACHE options, ensure that the operating environment meets the following requirements:

  • Intel or Intel-compatible 64-bit processor (Itanium or later).
  • Any 64-bit version of Windows.
  • 4 GB of RAM or more; you might have better performance if you use more than 8 GB.
  • SAS 9.2 for Windows.

Then follow these steps:

Specifying the Local Security Settings

In 32-bit environments starting with Windows XP Professional and above, the Lock pages in memory security setting must be set, so that each user who is running SAS has access to the extended memory. If a user does not have the correct permissions, then SAS will issue a warning message to the log.

System administrators can set the local security settings through the Start Menu. To set this value

  1. Open the Control Panel.
  2. Double click Administrative Tools.
  3. Double click Local Security Policy. The Local Security Settings window will open.
  4. Double click Local Policies.
  5. Double click User Rights Assignment.
  6. Double click Lock pages in memory. The Local Security Policy Setting window will open.
  7. Click Add. The Select User or Groups window will open.
  8. Select the user IDs or name of the group of users who need to run SAS with access to the extended memory.
  9. Click OK in the Select User or Groups window.
  10. Click OK in the Local Security Policy window.

    Note:   In the Local Security Policy window, you might see two check boxes: the Local Security Setting check box and the Effective Policy Setting check box. If the Effective Policy Setting check box is not selected for the users that you added, you will need to reboot your computer so that the new security settings will take effect.

Frequent Contributor
Posts: 129

Memcache on Windows 7 with UAC

This doesn't work on my system (9.3 on Win7x64). I get the following error message in the log even after I have changed the lock pages in memory option. (I recall that I previously got it work by disabling UAC, but I don't want to do that).

options memcache=4 ;

proc means data=hes.hes10bh;run;

ERROR: Cannot adjust the token privileges with error 1300. User probably does not have the right

       to lock pages in memory.

WARNING: Some installed physical memory may not be accessible. This may cause unexpected out of

         memory conditions.

Occasional Contributor
Posts: 9

Re: Memcache on Windows 7 with UAC

Same issue here.

The first time in a session when I create a table in a memlib library I get the same:

libname myMemLib "c:\temp" memlib;

data myMemLib.class;

  set sashelp.class;

run;

ERROR: Cannot adjust the token privileges with error 1300. User probably does not have the right to lock pages in memory.

WARNING: Some installed physical memory may not be accessible. This may cause unexpected out of memory conditions.

data myMemLib.class;

  set sashelp.class;

run;

<no error or warning>

libname myMemLb2 "c:\temp\2" memlib;

data myMemLb2.class;

  set sashelp.class;

run;

<no error or warning>

Error message appears after modifying security policy and also after running as admin.

Ask a Question
Discussion stats
  • 3 replies
  • 1021 views
  • 0 likes
  • 3 in conversation