Architecting, installing and maintaining your SAS environment

Local SAS Server Missing in SAS Enterprise Guide

Accepted Solution Solved
Reply
New Contributor
Posts: 2
Accepted Solution

Local SAS Server Missing in SAS Enterprise Guide

I'm trying to take the SAS Programming 1 e-Learning course on a laptop with Windows 7. The local SAS administrator installed SAS Foundation 9.4 and SAS Enterprise Guide 6.1 on my laptop, but when I open Enterprise Guide, I get the following message:

A local SAS server was not found and no metadata profile is being used. Without a SAS server you cannot open data or run SAS programs.

I only need to use local data for the e-Learning course; I don't need to connect to a remote server.

Does this sound like a configuration issue? Can anyone provide instructions on how to configure/start the local SAS server so that it's recognized by Enterprise Guide?

Thanks in advance for any assistance!


Accepted Solutions
Solution
‎04-09-2014 01:17 PM
New Contributor
Posts: 2

Re: Local SAS Server Missing in SAS Enterprise Guide

Thanks for the quick reply, Haikuo!

I think I found the reply here: How to run a program in EG5.1 without connecting to a server

After following this thread, I discovered that the core SAS software was not installed on the computer!

View solution in original post


All Replies
Respected Advisor
Posts: 3,124

Re: Local SAS Server Missing in SAS Enterprise Guide

Solution
‎04-09-2014 01:17 PM
New Contributor
Posts: 2

Re: Local SAS Server Missing in SAS Enterprise Guide

Thanks for the quick reply, Haikuo!

I think I found the reply here: How to run a program in EG5.1 without connecting to a server

After following this thread, I discovered that the core SAS software was not installed on the computer!

Valued Guide
Posts: 3,208

Re: Local SAS Server Missing in SAS Enterprise Guide

There can be a lot of reasons you are not seeing the local-server.
When installing SAS-base/foundation al lot of Windowsregistry settings are done. One of them is defining the "local server" process Eguide should use.

Possible causes:

- These registry settings are not implemented or available to your user.

- The top gotchas when moving to 64-bit SAS for Windows - The SAS Dummy There is bitness issue. Have all of 64-bit or all 32-bit but do not mixup.

  being before https://communities.sas.com/message/176534

- The two programs Eguide and SAS base have been put in different virtual machines not seeing each other

- ...  

---->-- ja karman --<-----
☑ This topic is SOLVED.

Need further help from the community? Please ask a new question.

Discussion stats
  • 3 replies
  • 13678 views
  • 0 likes
  • 3 in conversation