BookmarkSubscribeRSS Feed
🔒 This topic is solved and locked. Need further help from the community? Please sign in and ask a new question.
japsas100
Pyrite | Level 9

Dear All,

 

I am trying to open the smc from unix its throwing the below error:

Warning: No xauth data; using fake authentication data for X11 forwarding.
connect /tmp/.X11-unix/X0: Connection refused

 

I follow these steps:

export DISPLAY=:0
ssh -x myuser@app.myserver.com
cd /pub/sas/SASManagementConsole/9.4
./sasmc_console

 

I have clicked the 'enabled X11 forwarding' before opening the unix session 

1 ACCEPTED SOLUTION

Accepted Solutions
Anand_V
Ammonite | Level 13
After connecting to server via MobaXterm can you just run below commands?

sis$ cd /s01/sas/sashome/SASManagementConsole/9.3
sis$ ./sasmc

View solution in original post

20 REPLIES 20
Anand_V
Ammonite | Level 13
Can you try launching 'xclock' just to verify if the X11 connection works fine? Just type 'xclock' and hit enter. If the package is installed on your machine and all the X11 settings works fine it will launch a clock for you.

If the above works then try launching "/pub/sas/SASManagementConsole/9.4/sasmc" instead of "/pub/sas/SASManagementConsole/9.4/sasmc_console"
japsas100
Pyrite | Level 9

@Anand_V 

 

Here is output of clock command

sis$ xclock
-bash: xclock: command not found

Anand_V
Ammonite | Level 13
Yeah, it looks like you don't have the package installed. What client are you using to connect to the Unix Server? PuTTY/MobaXTerm/Or something else?
japsas100
Pyrite | Level 9

@Anand_V 

 

Thanks for the reply.

I am using Putty.

Anand_V
Ammonite | Level 13
OK, In-case of PuTTY you would need an X-Server running as well like X-Ming. Which X server software client are you using?
japsas100
Pyrite | Level 9

@Anand_V 

 

I have no clue which X server we are using. If you share steps I will check.

Anand_V
Ammonite | Level 13

I would suggest (If possible) try downloading the free version of MobaXterm (https://mobaxterm.mobatek.net/download.html). It has built-in X11 server and SFTP server. This link has steps on how to enable x11 for the session and connect to UNIX server. https://docs.computecanada.ca/wiki/Connecting_with_MobaXTerm/en

japsas100
Pyrite | Level 9

@Anand_V 

Do we need to download  MobaXterm in window env?

Anand_V
Ammonite | Level 13
Yes, its a client like PuTTY (with some added features into one)
japsas100
Pyrite | Level 9

@Anand_V 

 

Yes, I have downloaded the  MobaXterm. What is the next step?

Anand_V
Ammonite | Level 13

Connect to you server from which you were trying to launch SMC. Steps to connect here - https://docs.computecanada.ca/wiki/Connecting_with_MobaXTerm/en
Once In, launch SMC the way you did in the initial post.

Since, you haven't mentioned, If the X11 forwarding on your UNIX/Linux server is enabled or not. In-case it isn't you wont be able to launch SMC or any X-Windows enabled application.

You can verify it via two ways: 1) check the sshd_config file for value of parameter "X11Forwarding". It should be set to yes. This file is located under system path /etc/ssh.
2) Once successfully logged into server using MobaXterm you should see all green as below:

Anand_V_0-1585663730104.png

 

japsas100
Pyrite | Level 9

 

@Anand_V 

Thanks for the quick reply.

I have validated the below points.

1) check the sshd_config file for value of parameter "X11Forwarding". It should be set to yes. This file is located under system path /etc/ssh.

Ans: I can see sshd_config has X11Forwarding yes but ssh_config has X11Forwarding No

 

2) Once successfully logged into server using MobaXterm you should see all green as below:

Yes

 

When I entered the command xclock its still throwing the error.


is$ xclock
-bash: xclock: command not found

Kurt_Bremser
Super User

ssh_config on the server does not bother you, as it controls the client started on the server; you only use sshd by logging on.

xclock is a standard X app used to display a clock in graphic mode; it is not installed on your server, and not needed except for checking that a X protocol connection is present.

 

Once you have started your X Window server and after that made your connection with putty, you should be able to start SMC on the server and have it display on your desktop.

japsas100
Pyrite | Level 9

@Kurt_Bremser @Anand_V 

Still, I am not able to open smc. I follow the below steps.

I can see X server running before login to putty its showing (stop X server current display into 192.XXXX.XX(

 

japsas100_0-1585670515579.png

 

I can see X server running is still running.

sis$ export DISPLAY=:0
sis$ echo $DISPLAY
:0

sis$ ssh -X sh@xxxxxxxxx.cx

password:XXXXXX

Warning: No xauth data; using fake authentication data for X11 forwarding.


sis$ cd /s01/sas/sashome/SASManagementConsole/9.3
sis$ ./sasmc
connect /tmp/.X11-unix/X0: Connection refused

 

suga badge.PNGThe SAS Users Group for Administrators (SUGA) is open to all SAS administrators and architects who install, update, manage or maintain a SAS deployment. 

Join SUGA 

CLI in SAS Viya

Learn how to install the SAS Viya CLI and a few commands you may find useful in this video by SAS’ Darrell Barton.

Find more tutorials on the SAS Users YouTube channel.

Discussion stats
  • 20 replies
  • 5556 views
  • 3 likes
  • 3 in conversation