Architecting, installing and maintaining your SAS environment

JBoss version required by SAS 9.3?

Accepted Solution Solved
Reply
Occasional Contributor
Posts: 8
Accepted Solution

JBoss version required by SAS 9.3?

I'm installing a new SAS 9.3 environment and am in the process of installing the middle tier. I installed JBoss AS 7.1, but the Deployment Wizard is not recognizing it. The wizard says JBoss Application Server 4.3 is required. Is it necessary to have the Enterprise JBoss version and not the Community version?


Accepted Solutions
Solution
‎06-01-2012 10:51 AM
SAS Employee
Posts: 102

Re: JBoss version required by SAS 9.3?

SAS does indeed support both the AS version as well as the EAP version.  However, AS 7.1 is a higher version than is currently supported, which is why the Deployment Wizard is balking.  Check out the information on the following page for a description of supported versions:

http://support.sas.com/resources/thirdpartysupport/v93/appservers/jbosssw.html

A link on this page takes you to additional support information for the Community and EAP versions of JBoss (http://support.sas.com/resources/thirdpartysupport/jbossSupport.html).

View solution in original post


All Replies
Contributor
Posts: 55

Re: JBoss version required by SAS 9.3?

The Enterprise JBoss version is not required.  Go to the JBoss Application Server Support for SAS® 9.3 page at http://support.sas.com/resources/thirdpartysupport/v93/appservers/jbosssw.html.  I am about to install the jboss-5.1.0.GA version in my environment, and I confirmed with Tech Support and the SAS Installer that it is supported in 9.3.  Ensure that you have the 64-bit version of JBoss, this is a new requirement in 9.3.

Solution
‎06-01-2012 10:51 AM
SAS Employee
Posts: 102

Re: JBoss version required by SAS 9.3?

SAS does indeed support both the AS version as well as the EAP version.  However, AS 7.1 is a higher version than is currently supported, which is why the Deployment Wizard is balking.  Check out the information on the following page for a description of supported versions:

http://support.sas.com/resources/thirdpartysupport/v93/appservers/jbosssw.html

A link on this page takes you to additional support information for the Community and EAP versions of JBoss (http://support.sas.com/resources/thirdpartysupport/jbossSupport.html).

Occasional Contributor
Posts: 8

Re: JBoss version required by SAS 9.3?

Thank you both. I will download the version in the link and give it a try.

Thanks again!

🔒 This topic is solved and locked.

Need further help from the community? Please ask a new question.

Discussion stats
  • 3 replies
  • 1897 views
  • 3 likes
  • 3 in conversation