Architecting, installing and maintaining your SAS environment

Issue with system variable %PATH% after installation of SAS 9.4M3

Accepted Solution Solved
Reply
Contributor
Posts: 26
Accepted Solution

Issue with system variable %PATH% after installation of SAS 9.4M3

[ Edited ]

Hi,

 

I've noticed a rather peculiar behaviour in a DOS box after installing SAS 9.4M3 on a Windows 7 x64 machine. When the installation has finished correctly, and I open a new Command Prompt, several programs located in C:\Windows\system32 are no longer available: net, ipconfig, xcopy, ... Manually adding the directory C:\Windows\system32 (or %SystemRoot%\system32) at the end of the PATH variable makes them available again.

 

Before launching setup.exe (from a batch file), the DOS instruction echo %path% gives me C:\ProgramData\Oracle\Java\javapath;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\ 

 

When the installation is finished, opening a new Command Prompt and typing echo %path% gives me (in pink the added code) C:\ProgramData\Oracle\Java\javapath;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\;C:\PROGRA~2\Java\JRE18~1.0_6\bin\client;C:\Program Files\SASHome94M3\Secure\ccme4;C:\Program Files\SASHome94M3\x86\Secure\ccme4

 

If I then add ;%systemroot%\system32 at the end, everything is back in order, although %systemroot%\system32 is already in the PATH variable, right in the beginning.

 

Anybody noticed the same behaviour? Any ideas or solutions?

 

Thank you,

Michel


Accepted Solutions
Solution
‎03-01-2017 07:59 AM
Contributor
Posts: 26

Re: Issue with system variable %PATH% after installation of SAS 9.4M3

After many e-mail exchanges, a series of tests and even a phone call from the manager of SAS Customer Support in Belgium, SAS Tech Support was unable to reproduce the problem I'm having. I have a workaround, which is to add

 

;%systemroot%\system32

 

at the end of the %PATH% system variable, which is fine by me.

 

As @anja stated, SAS Tech Support is great, they go all the way in finding a solution. In some cases there is no solution, but hey, that's life Smiley Wink

View solution in original post


All Replies
SAS Super FREQ
Posts: 291

Re: Issue with system variable %PATH% after installation of SAS 9.4M3

Hi there,

 

it looks like you are working with Tech Sup now?

Is the problem solved or are you guys testing things right now?

 

Please let me know if there is anything we could help you with.

Tech Sup is a great place for troubleshooting. These guys are brilliant.

 

Thanks

Anja

Contributor
Posts: 26

Re: Issue with system variable %PATH% after installation of SAS 9.4M3

Hi Anja,

 

I'm working on the issue with Tech Support Belgium. I'll update this topic as soon as we've come up with a solution.

 

We think there may be an issue with the 8.3 convention on the computer, but long filenames are activated, and 8.3 equivalent short filenames are defined.

 

What puzzles me, and what Tech Support is looking into, is why the Setup program changes every C:\Windows in the PATH to %systemroot% and why the path to the Java runtime is in 8.3 format.

 

I performed an additional test where I replaced the 8.3 pathname to the JRE to long filename convention and after that, the programs in C:\Windows\system32 were available again:

 

Before:

C:\ProgramData\Oracle\Java\javapath;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\;C:\PROGRA~2\Java\JRE18~1.0_6\bin\client;C:\Program Files\SASHome94M3\Secure\ccme4;C:\Program Files\SASHome94M3\x86\Secure\ccme4

 

Afer:

C:\ProgramData\Oracle\Java\javapath;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\Java\jre1.8.0_60\bin\client;C:\Program Files\SASHome94M3\Secure\ccme4;C:\Program Files\SASHome94M3\x86\Secure\ccme4

 

These are the findings I sent to Tech Support, I'm awaiting their response.

 

Michel

Super User
Posts: 6,936

Re: Issue with system variable %PATH% after installation of SAS 9.4M3

Oh, the joys of Windows (aka DOS on steroids)!

---------------------------------------------------------------------------------------------
Maxims of Maximally Efficient SAS Programmers
Solution
‎03-01-2017 07:59 AM
Contributor
Posts: 26

Re: Issue with system variable %PATH% after installation of SAS 9.4M3

After many e-mail exchanges, a series of tests and even a phone call from the manager of SAS Customer Support in Belgium, SAS Tech Support was unable to reproduce the problem I'm having. I have a workaround, which is to add

 

;%systemroot%\system32

 

at the end of the %PATH% system variable, which is fine by me.

 

As @anja stated, SAS Tech Support is great, they go all the way in finding a solution. In some cases there is no solution, but hey, that's life Smiley Wink

☑ This topic is SOLVED.

Need further help from the community? Please ask a new question.

Discussion stats
  • 4 replies
  • 190 views
  • 3 likes
  • 3 in conversation