Architecting, installing and maintaining your SAS environment

Installing SAS 9.4 on windows 8.1

Reply
Regular Contributor
Posts: 180

Installing SAS 9.4 on windows 8.1

Hello all,

I am trying to install my SAS 9.4 on windows 8.1, and I have encountered the most weird error, never seen anything like this.

I ran the setup file, and choose "install SAS software", and then this message came:

"This machine is currently using windows 7 pro 64 bit. However, you need windows 7 pro 64 SP1 or later, please refer to the document....."

Ha ? I have windows 8.1....legal, activated...what makes SAS think I have windows 7 pro ? When I press OK, I go backwards, meaning, I can't install....

I went to my PC's system, it said windows 8.1. I went to the Microsoft website, where you can check your version online, it said windows 8.1 Only SAS thinks I have windows 7...how do I get out of this situation and install the software ?

Will appreciate a solution !

Thanks.

Super User
Posts: 5,257

Re: Installing SAS 9.4 on windows 8.1

Do you have 8.1 Pro?

Typical question for SAS tech support.

Data never sleeps
Super User
Posts: 3,108

Re: Installing SAS 9.4 on windows 8.1

These might help. Check your SAS 9.4 has at least the minimum maintenance level.

http://blogs.sas.com/content/sasdummy/2013/11/06/sas-on-windows-8/

http://support.sas.com/kb/46/876.html

Ric
N/A
Posts: 1

Re: Installing SAS 9.4 on windows 8.1

Good day!

I just received SAS9.4 TS1M1 x64Edition which is SAS Education-Analystical Suite, I have windows 8.1 x64 but when I go through your link and check the OS support requirement, it mention that it support only for the SAS Education Analytical Suite starting in SAS 9.4 TS1M0, Rev. 13w26.

Does this mean that if I install TS1M1 version on my machine, it will failed? Please advice.

Thank you

Regards

Ric

Regular Contributor
Posts: 180

Re: Installing SAS 9.4 on windows 8.1

yes, I do have win 8.1 pro.

according to the links, my system matches the requirements. this is odd.

Valued Guide
Posts: 3,208

Re: Installing SAS 9.4 on windows 8.1

The setup is using java and xml processing to check all kind of things.

This is the way SAS has build their own dedicated process (java based not msi based) and there must be something wrong. with that.

For sure SAS should repair that.

If you are a techy and want to invest that all you could do a research on those checks by yourself.

---->-- ja karman --<-----
Regular Contributor
Posts: 244

Re: Installing SAS 9.4 on windows 8.1

I ran into the same problem, actually, a while back.  If I recall correctly, I think I fixed it by installing in compatibility mode for windows 7.

And agreed, SAS uses a strange and poorly managed installation method.  No idea why they don't just use MSIs or Installshield or whatnot.  9.4 and 9.3 are much better than 9.1 was (... runs screaming ...), but still not the best installation experience.

Regular Contributor
Posts: 180

Re: Installing SAS 9.4 on windows 8.1

snoopy,

you were kind of right ! The problem was that it WAS checked to install in windows 7 compatibility mode. I didn't check it...so anyway I removed the check and then it went on, it failed installing, but when I tried again it worked and now I have it working.

Thanks to everyone else for helping !

Smiley Happy

Super Contributor
Posts: 273

Re: Installing SAS 9.4 on windows 8.1

Hi

i think that you have the ticket to  SAS9.4 TS1M1

SAS 9.4 TS1M0, Rev. 13w26   means  9.4.0  of 2013 week 26


HTH

Andre Wielki

SAS Employee
Posts: 33

Re: Installing SAS 9.4 on windows 8.1

HI BlueNose and Andre. As Andre says SAS 9.4 TS1M0 13w26 means you have maintenance level 0 released at week 26 of 2013. Since your order is TS1M1 you have maintenance level 1 which came out in 13w51. Your order is newer than 13w26 so you should be fine.

Regular Contributor
Posts: 180

Re: Installing SAS 9.4 on windows 8.1

Hello jag,

I eventually managed to install SAS on windows 8.1. The problem was in the installation file, for some known reason, it was marked by default to run in a windows 7 compatibility mode. Once I have noticed that and removed this mark, the installation went smooth. It took me a few days to realize what is wrong.

Ask a Question
Discussion stats
  • 10 replies
  • 8775 views
  • 0 likes
  • 8 in conversation