Architecting, installing and maintaining your SAS environment

In Managment Console, within Workspace Server macro variable the path

Accepted Solution Solved
Reply
Occasional Contributor
Posts: 12
Accepted Solution

In Managment Console, within Workspace Server macro variable the path

Hi,

When User open Enterprise Guide or any SAS Application and go save as....

Under Servers the path is set in SMC. As my attachmewnt indicates.

 

I would like to set that path as a macro variable as many business units have their own folder, I want them not to browse

where they don't have access.

 

Please see my attachment for more detail.

 

Thank you Deon


Accepted Solutions
Solution
‎03-30-2016 05:07 AM
Regular Contributor
Posts: 172

Re: In Managment Console, within Workspace Server macro variable the path

Posted in reply to Deonjpret

Deon,

 

I had the same problem with my environment.  We have different business units that all use a single grid environment, and each unit has their own secure file system.  I had specific Unix groups created for each business group and these would be the primary group ID for any user in that business group.  We then set the permissions on the file system so that only users in that group could access the file system, and then I created autoexec code that runs any time a user connects. The autoexec code checks the user's primary group ID and then create the symbolic link to their relevant file system/directory within their /home/$USER directory. I'd be happy to help out if you can provide me with a few things:

 

1. The code you're currently using to create "&workpath" macro variable.

2. Do you have x-commands enabled for your workspace server? (This is necessary if you want to use SAS autoexec code to create the symbolic links for the users)

View solution in original post


All Replies
Trusted Advisor
Posts: 1,307

Re: In Managment Console, within Workspace Server macro variable the path

Posted in reply to Deonjpret

Hi,

 

is it not sufficient to you with the users just making use of the SASUSER library and their personal SAS folder?

 

About your question: did you already tried to set the macro variable (_workpath)in the autoexec_usermods of the Workspace server and call that macro variable from the Custom path as /sas/dev/data/userdata/.&_workpath?

 

When you set this, you will need to restart the Object Spawner or refresh the SASApp.

 

PS. maybe you could get additional support on the Administration Community.

Super User
Posts: 5,424

Re: In Managment Console, within Workspace Server macro variable the path

Posted in reply to JuanS_OCS

Moved the post to a forum that better matches the question.

Data never sleeps
Regular Contributor
Posts: 172

Re: In Managment Console, within Workspace Server macro variable the path

Posted in reply to Deonjpret
Basically what Juan said, I think you should have auto exec code for the workspace server that creates the the work path for the user by creating a symbolic link in their home directory.

This is what i am doing I in my environment.
Let us know it you need mor details
Occasional Contributor
Posts: 12

Re: In Managment Console, within Workspace Server macro variable the path

Posted in reply to Timmy2383

I have tried the macro variable, and it does not resolve. I like your idea of a symbolic link to be created. Can you please share more so I can test and see if it resolves my problem. We have 600+ users which is onboarding this new environment and I just don't want to much manual work. This seems to be a once off. Please remember what is my objective: When in a SAS Solution, and I go file Save As.... every user should be able to go to his own Business unbit folder.

 

Thx

Deon

Trusted Advisor
Posts: 1,307

Re: In Managment Console, within Workspace Server macro variable the path

Posted in reply to Deonjpret

After the change, I would expect you restarted the object spawner.

 

Have you already tried an operating system variable? In Windows "!USERNAME" works nicely.

What I do for my EGuide users is to define, in Workspaceserver\sasv9_usermods.cfg is to define:

-SASUSER "D:\mypath\!USERNAME"

 

Which works like a charm. It is not the filepath, but the users can use it for their own stuff

Solution
‎03-30-2016 05:07 AM
Regular Contributor
Posts: 172

Re: In Managment Console, within Workspace Server macro variable the path

Posted in reply to Deonjpret

Deon,

 

I had the same problem with my environment.  We have different business units that all use a single grid environment, and each unit has their own secure file system.  I had specific Unix groups created for each business group and these would be the primary group ID for any user in that business group.  We then set the permissions on the file system so that only users in that group could access the file system, and then I created autoexec code that runs any time a user connects. The autoexec code checks the user's primary group ID and then create the symbolic link to their relevant file system/directory within their /home/$USER directory. I'd be happy to help out if you can provide me with a few things:

 

1. The code you're currently using to create "&workpath" macro variable.

2. Do you have x-commands enabled for your workspace server? (This is necessary if you want to use SAS autoexec code to create the symbolic links for the users)

☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 6 replies
  • 738 views
  • 1 like
  • 4 in conversation