Architecting, installing and maintaining your SAS environment

I need help activating stored processes reports in Environment Manager

Reply
Occasional Contributor
Posts: 16

I need help activating stored processes reports in Environment Manager

When I open up Report Center under the analyze tab, and try to run any of the stored process reports under products, I get an some kind of error. And the report is empty or doesn't have useful information. Does anyone know how to configure this?

 

Thank you so much

Trusted Advisor
Posts: 1,141

Re: I need help activating stored processes reports in Environment Manager

Hi,

 

what kind of errors do you receive? This would help a lot to understand your problem.

Thank you,

Kind regards,

Juan

Super User
Posts: 3,101

Re: I need help activating stored processes reports in Environment Manager

Are you by any chance doing this on a SAS VA installation? There is a known problem that some of these reports use SAS procedures not present in SAS VA like PROC FREQ and PROC TABULATE.

 

If this is the case then please raise this issue with SAS Tech Support. The more users that raise this problem the greater chance something will be done to resolve it. 

Occasional Contributor
Posts: 13

Re: I need help activating stored processes reports in Environment Manager

Hello, I am looking for a report in Environment Manager that tells me how many times a user has ran the stored process that I created?  

SAS Super FREQ
Posts: 291

Re: I need help activating stored processes reports in Environment Manager

Hi,

 

as Juan mentioned, knowing the error could help us further troubleshoot.

 

What comes to mind when having problems with the Reports Center is that something might have gone

wrong with the initialization. I saw the behavior you described before.

 

Did you follow these steps:

http://go.documentation.sas.com/?cdcId=evcdc&cdcVersion=2.5_M1&docsetId=evug&docsetTarget=p0h7p9v8da...

 

What version of SAS and maintenance release are you using? That's important too as the features and functionality

in Environment Manager depend on the version. SAS 9.4 M3/M4 is using Env Mgr 2.5, which is the latest.

 

You could check the log files to see if there are any errors that help troubleshoot this behavior further.

Take a look at the following log files.

 

SAS® Environment Manager Server

/SAS-configuration-directory/Lev1/Web/SASEnvironmentManager/server-5.x.0-EE/logs/server.log

/SAS-configuration-directory/Lev1/Web/SASEnvironmentManager/server-5.x.0-EE/logs/bootstrap.log

SAS® Environment Manager Agent

/SAS-configuration-directory/Lev1/Web/SASEnvironmentManager/agent-5.x.0-EE/log/agent.log

 

It sounds as if the reports / stored processes have not been initialized.

 

Feel free to post the log files as attachment if you'd find any errors, I'll be happy to take a look at it.

 

Best

Anja

Ask a Question
Discussion stats
  • 4 replies
  • 348 views
  • 3 likes
  • 5 in conversation