Architecting, installing and maintaining your SAS environment

How to exclude particular library while exporting SAS SPK package through code?

Reply
Contributor
Posts: 63

How to exclude particular library while exporting SAS SPK package through code?

Hi All,

 

I am trying to export SAS SPK package with export utility script, what i want to know is how can i exclude particular library while exporting the SAS Package through code?

 

Thanks in advance.

 

Regards,

Kaushal 

Regular Contributor
Posts: 211

Re: How to exclude particular library while exporting SAS SPK package through code?

Posted in reply to kaushalsolanki
I have no idea, but what if you restrict the library with permissions for the user running the extract ? This way the library become ‘invisible’.
Super User
Posts: 3,299

Re: How to exclude particular library while exporting SAS SPK package through code?

Posted in reply to kaushalsolanki

It only takes a few seconds to delete a library in SAS Management Console. Why not just export all of them then delete the ones you don't want after importing?

Frequent Contributor
Posts: 134

Re: How to exclude particular library while exporting SAS SPK package through code?

[ Edited ]
Posted in reply to kaushalsolanki

There are more than one way to skin a cat.

 

As mentioned above, over-protect the specific library with ACT(s) that prevent(s) the service account in metadata which  does the export  to access the library reference. Questionable.

 

Or, export selectively some metadata object types and exlude library ref (-types / -exclude etc.). Easier but still questionable.

 

Or, maybe better still if you can, change the folder path storing the Library reference to another branch apart from the root folder you want to export.

 

 

 

 

Trusted Advisor
Posts: 1,414

Re: How to exclude particular library while exporting SAS SPK package through code?

[ Edited ]
Posted in reply to kaushalsolanki

Great input from everybody Smiley Happy

 

I wonder why you want to export a folder tree and exclude some paths from the export. Perhaps because of the type of data contained on those paths?

 

Yet another option for those scenarios, the -excludeSubTypes parameters can come to the rescuehttp://documentation.sas.com/?docsetId=bisag&docsetTarget=n008xsxs34mvcwn1qrgcmugpzu6i.htm&docsetVer...

Ask a Question
Discussion stats
  • 4 replies
  • 198 views
  • 6 likes
  • 5 in conversation