Architecting, installing and maintaining your SAS environment

How/Where do I set the keepalive parameter to prevent network timeouts

Accepted Solution Solved
Reply
Occasional Contributor
Posts: 6
Accepted Solution

How/Where do I set the keepalive parameter to prevent network timeouts

Greetings,

 

Environment: SAS 9.4M2 with EG 7.1, Win 2012 Server, Win 7 64 client.

Problem:        Users EG sessions timing out when doing explicit sql to remote servers.

FIX:                I'm supposed to set the KeepAlive Parameter

ISSUE:           I don't know where to add the parameter.

 

BackGround: We have finally received our new physical server (96 cores, 256G ram, 6 TB storage) which is at a remote data center. We are migrating the users from the local virtual server to the new physical server. These users are banging large sql queries explicitly so the backend database server is processing the query. With the new network rules the users are timing out after an hour of inactivity while the sql query is processing. The EG screen reports that the session is still active until the user tries to do something and then is informed that the server is disconnected.

 

Additional QuestionS:       IS there a setting that can be done at the client workstation.

                                         After KEEPALIVE is set, what parameter do I search for via EG Proc Options.

 

Any and ALL help would be appreciated,

Thanks,

Jerry Coppa - SAS Admin at DHS PA GOV


Accepted Solutions
Solution
Thursday
Super User
Posts: 3,112

Re: How/Where do I set the keepalive parameter to prevent network timeouts

[ Edited ]

The most likely cause of this issue is a firewall timeout rule. This can be fixed in a variety of ways:

 

 

An IT network specialist should be able to advise you on the first 2 options. These are in my opinion the best options as they minimise maintenance and support issues.

View solution in original post


All Replies
Solution
Thursday
Super User
Posts: 3,112

Re: How/Where do I set the keepalive parameter to prevent network timeouts

[ Edited ]

The most likely cause of this issue is a firewall timeout rule. This can be fixed in a variety of ways:

 

 

An IT network specialist should be able to advise you on the first 2 options. These are in my opinion the best options as they minimise maintenance and support issues.

Occasional Contributor
Posts: 6

Re: How/Where do I set the keepalive parameter to prevent network timeouts

I like the idea of keepalive utility at the workstation level - how/where do I get it.

Super User
Posts: 3,112

Re: How/Where do I set the keepalive parameter to prevent network timeouts

[ Edited ]

Try a Google search or better still talk to one of your IT network guys as they are the experts in this area and are in the best position to fix the problem for you.

 

Here is one I found: http://tcp.software.informer.com/download-tcp-keep-alive-utility/

 

NB: I've never used this option so you will need to test this out for yourself.

New User
Posts: 1

Re: How/Where do I set the keepalive parameter to prevent network timeouts

Can you guys provide more detail about the option "Configure the TCP/IP TimeOut parameter to just below the firewall limit: http://support.sas.com/kb/47/825.html"?

 

How can I do that?

Occasional Contributor
Posts: 6

Re: How/Where do I set the keepalive parameter to prevent network timeouts

In the SAS Management Console -> Server Manager -> SASApp -> SASApp - Workspace server -> the options tab

in the object server parameters: keepalive=900

this works well as out firewall time out at 60 minutes. We have not had a single issue since applying this.

Capture.JPG

☑ This topic is SOLVED.

Need further help from the community? Please ask a new question.

Discussion stats
  • 5 replies
  • 2224 views
  • 0 likes
  • 3 in conversation