Architecting, installing and maintaining your SAS environment

HP-UX | Install SAS Enterprise Miner

Reply
Contributor
Posts: 59

HP-UX | Install SAS Enterprise Miner

Hi all,

 

I've just finish a SAS 9.4 installation on HP-UX. I used an standard plan, (called SAS Enterprise Miner, SAS Text Miner, 1 machine). SAS Metadata Server and Workspace Server are on the same machine, is not distributed.

 

The installation process completed successfully but during SAS Miner configuration the following error appear:

 

Property "dminemid.dependson.webappsrv.fqid" has not been set
[GetObjectProperties] Using FQID: ${dminemid.dependson.webappsrv.fqid}
[GetObjectProperties] *************** ERROR ****************
[GetObjectProperties] *************** ERROR ****************
[GetObjectProperties] *************** ERROR ****************
[GetObjectProperties] Object property retrieval failed since requested fqid is an unexpanded property: ${dminemid.dependson.webappsrv.fqid}
[GetObjectProperties] Ant property is not set: webappsrv.legal.name
[GetObjectProperties] No configured instance was found using the given fqid for: webappsrv

 

 

How I can resolve it in order to have SAS Miner ready to use? 

SAS Employee
Posts: 101

Re: HP-UX | Install SAS Enterprise Miner

[ Edited ]

Do you recall if you saw 'SAS Web Application Server' as an item being configured in the Deployment Wizard?

Contributor
Posts: 59

Re: HP-UX | Install SAS Enterprise Miner

Hi @dpage

 

As I mentioned, I used a standard plan included on Depot. Please see attached the plan selected and, yes, SAS Web Application was included. In fact, SAS Web Applications appears on SASHome directory.

 

Any idea?

 

Regards, 


Plan 3.pngPlan1.png
Plan2.pngPlan4.png
SAS Employee
Posts: 101

Re: HP-UX | Install SAS Enterprise Miner

Do you have a vfabrictcsvr_configure*.log in your Lev1/Logs/Confgure path (sorry about the plan file, I missed that comment). What version of Enterprise Miner are you installing (I see SAS 9.4, but not a specific Enterprise Miner release) 

Contributor
Posts: 59

Re: HP-UX | Install SAS Enterprise Miner

Hi @dpage

 

Thanks for your help. Following the requested log. I'm installing SAS EM 14.2.

 

Regards, 

SAS Employee
Posts: 101

Re: HP-UX | Install SAS Enterprise Miner

That log shows a failure trying to write to the /etc/opt/vmware/vfabric directory (since it failed, things that depend on it, also fail)From the log:

Here are the manual steps:

  1. Logon as root user
  2. Create the directory /etc/opt/vmware/vfabric/
  3. chown -R "Current SAS install user name" /etc/opt/vmware/vfabric/
  4. chgrp -R "Group name of current SAS install user" /etc/opt/vmware/vfabric/

Contributor
Posts: 59

Re: HP-UX | Install SAS Enterprise Miner

Hi @dpage,

 

Yes, I found that error. I've just create the folder with the correct permission and I'm trying again in this moment.

 

Regards

Contributor
Posts: 59

Re: HP-UX | Install SAS Enterprise Miner

Hi @dpage,

 

Now, a new error appears:

 

2017-07-20 09:37:25,647 [main] ERROR com.sas.sdw.SDWExceptionHandler - java.io.FileNotFoundException: /sas9/config/Lev2/Web/WebAppServer/SASServer1_1/conf/server.xml (No such file or directory (errno:2))

 

In fact, there is no "server.xml" on that location. Any sugestion to resolve it and continue with the configuration process?

 

Regards, 

SAS Employee
Posts: 101

Re: HP-UX | Install SAS Enterprise Miner

It depends on where / when (how did you get back from the Enterprise Miner failure to Web Application Server configuration). You might be better off to open a Tech Support track to reach a faster resolution., 

Ask a Question
Discussion stats
  • 8 replies
  • 328 views
  • 1 like
  • 2 in conversation