Architecting, installing and maintaining your SAS environment

Execute the autoexec.sas on the Core of Grid when you have multiple machine on Core

Reply
Occasional Contributor
Posts: 12

Execute the autoexec.sas on the Core of Grid when you have multiple machine on Core

Good day,

 

We have two machine for SAS Grid Core and one for Solution. On Solution I got it right to get the user generic autoexec.sas to be executed during the start of a session against the SASApp Solution connection. I used the autoexec_usermod.sas in the WorkspaceServer.

 

But doing it against the Core, I did the reference in both machines autoexec_usermods.sas in the WorkspaceErver and the Barch server on the SASAppCore and the autoexec_usermods.sas is not executed.

 

Please help.

We have SAS 9.4 M3

 

Thank

Deon

 

 

Trusted Advisor
Posts: 1,141

Re: Execute the autoexec.sas on the Core of Grid when you have multiple machine on Core

Hi,

 

the autoexec.sas and sasv9 files should have some includes and paths, pointing to the autoexec_usermods and sasv9_usermods. If you can follow those path, you will see what files are being executed for the Workspace Server and the Batch Server on the Grid environment of yours.

 

I hope this can help a bit.


Regards,

Juan

Occasional Contributor
Posts: 12

Re: Execute the autoexec.sas on the Core of Grid when you have multiple machine on Core

Hi Juan,

 

As I tried to explain. Solution Grid has 1 server and Core Grid has two machines. I have made the needed changes to the Solution Grid - Workspace Server autoexec_usersmods.sas and that works. All the macro etc are ready for use. But on Core I made the same change on Workspaces Server autoexec_usermods.sas - both machine, but the macros are not seen or ready for use. So I did it on the Batch Server in Core autoexec_usermods.sas. No, the dame thing. It needs to be done differently. Please help. 

Trusted Advisor
Posts: 1,141

Re: Execute the autoexec.sas on the Core of Grid when you have multiple machine on Core

Hi,

 

I think you managed to explain yourself well, I could understand your point.

 

Please also consider my point: the only way you have to know why a code on an autoexec is bein executed or not is:

 

- See the logs and ensure that code is not being executed: which I could understand you did already.

- Track the execution path thorugh the includes on your SASApp and each of your SAS spawned servers, whicht hey should be the same on your "Grid Core" servers same as on your "Grid Solution" server,as you expect. But there could be differences on the configuration from defaults, and that is what you need to check.

 

Also, if you have trouble with that, you can ask SAS Technical Support or SAS professional Services to do this for you.

Moderator
Posts: 238

Re: Execute the autoexec.sas on the Core of Grid when you have multiple machine on Core

First question: What are you trying to achieve with different autoexec.sas files?

Reason: There may be a better way.

 

If you are running on a SAS/Grid, in v9.4 there are now SAS Grid Option Sets, which allow you to effectively apply default Grid/Config/Options as well as effectively applying conditional Grid/Config/Options, all from within the Logical Grid Server in Management Console - centralised management, no need to modify individual server-based files. Note: Not just Grid options, but also SAS configs and SAS options.

 

So, can you clarify your requirements (for which you think different autoexec.sas files might be a solution)?

 

(And the reason I picked up on this - I am presenting a paper as SAS Global Forum next week on SAS Grid Option Sets. If you are coming, feel free to drop in. Otherwise happy to discuss online.)

Occasional Contributor
Posts: 12

Re: Execute the autoexec.sas on the Core of Grid when you have multiple machine on Core

[ Edited ]

Hi,

 

I have tried my hand at a better explanation. Sorry for the confusion. Please see the attachment supporting the following:


As I tried to explain. Solution Grid has 1 server and Core Grid has two machines. I have made the needed changes to the Solution Grid - Workspace Server autoexec_usersmods.sas and that works. All the macro etc are ready for use. But on Core I made the same change on Workspaces Server autoexec_usermods.sas - both machine, but the macros are not seen or ready for use. So I did it on the Batch Server in Core autoexec_usermods.sas. No, the dame thing. It needs to be done differently. Please help.

Ask a Question
Discussion stats
  • 5 replies
  • 510 views
  • 0 likes
  • 3 in conversation