Architecting, installing and maintaining your SAS environment

ERROR: Insufficient authorization to access PIPE.

Reply
New Contributor
Posts: 4

ERROR: Insufficient authorization to access PIPE.

Hi,

I am trying to send a mail through SAS. This is the code I am using to send mail as a HTML from SAS. But when I run this code I am getting ERROR: Insufficient authorization to access PIPE error. I have enable XCMD option in SMC and tried to refresh Object_Spawner  in SMC only. I am not sure which step is going wrong but this error keeps coming. Please help me in resolving this issue.

FILENAME mail EMAIL TO="abc@xyz.com"

SUBJECT="HTML OUTPUT" CONTENT_TYPE="text/html";

ODS LISTING CLOSE;

ODS HTML BODY=mail;

PROC PRINT DATA= sample;

RUN;

ODS HTML CLOSE;

ODS LISTING;

Super User
Posts: 7,833

Re: ERROR: Insufficient authorization to access PIPE.

Posted in reply to swetha_kv

Use PROC OPTIONS to verify that XCMD is set.

I also suggest you google for the

ERROR: Insufficient authorization to access PIPE

phrase and browse through the results, as those may reveal another reason for your problem

---------------------------------------------------------------------------------------------
Maxims of Maximally Efficient SAS Programmers
New Contributor
Posts: 4

Re: ERROR: Insufficient authorization to access PIPE.

Posted in reply to KurtBremser

Hi,

I have used Proc options to check the XCMD . It shows NXCMD only though I checked the option "Allow XCMD" in SAS Management Console. Is there any way to refresh the server. I tried all options which came by searching in Google.

Thanks

Super User
Posts: 7,833

Re: ERROR: Insufficient authorization to access PIPE.

Posted in reply to swetha_kv

After changing the value in SMC, you need to restart the object spawner, since this is the one that sets the option on the commandline.

---------------------------------------------------------------------------------------------
Maxims of Maximally Efficient SAS Programmers
New Contributor
Posts: 4

Re: ERROR: Insufficient authorization to access PIPE.

Posted in reply to KurtBremser

I tried to restart using below instruction which was available in sas support:


Modify an Object Spawner Definition

To modify an object spawner definition by using the SAS Management Console, follow these steps:

  1. Start SAS Management Console and connect to a metadata repository.
  2. In the SAS Management Console navigation tree, expand the Server Manager to find the object spawner that you want to modify.
  3. Right-click the icon for the object spawner and select Properties from the pop-up menu.
  4. Select the appropriate tabs, and enter the necessary changes.For more information, refer to SAS Management Console online Help.
  5. When you are finished, click OK to return to the SAS Management Console main window.
  6. Restart the object spawner.For more information, see "Operating Your Servers" in SAS Intelligence Platform: System Administration Guide.


But, looks like XCMD option is not getting set inspite of refreshing object spawner as instructed above

New Contributor
Posts: 4

Re: ERROR: Insufficient authorization to access PIPE.

Posted in reply to swetha_kv

Hi,

 

Slightly off on a tangent. Are you sure the noxcmd setting is what is preventing you sending email?

 

I can send email using the filename option in Enterprise Guide with noxcmd on.  You can get some misleading errors from the email filename if the email options are not setup correctly.

 

Check the options with:

Proc options group=email; run;

Particularly emailsys.

 

Jon

Trusted Advisor
Posts: 3,215

Re: ERROR: Insufficient authorization to access PIPE.

Posted in reply to JonathanWilliamson

The setting is a command-line option for the WS or SP after restarting the service.
I could be have set at a config file.

 

Needing to send email it is better the use to direct interface (smtp 25) unless you are blocked by outdated old SAS version and new very demanding mail-server.  What is you SAS environment (server?) and waht versions are there arround?

---->-- ja karman --<-----
New Contributor
Posts: 2

Re: ERROR: Insufficient authorization to access PIPE.

Posted in reply to swetha_kv

This blog post from Paul Homes, https://platformadmin.com/blogs/paul/2011/06/noxcmd/, might help providing additional instructions for diagnosing and enabling/disabling the XCMD functionality…if indeed the xcmd is what holding you off from sending HTML-format email.

 

The blog mentions the possible multiple NOXCMD location settings on different server instances (workspace, pooled workspace, STP, SASMeta), so you just want to be sure the specific NOXCMD setting you made earlier reflect the way how the code is called.

 

Hope this helps!

Ask a Question
Discussion stats
  • 7 replies
  • 2328 views
  • 1 like
  • 5 in conversation