Architecting, installing and maintaining your SAS environment

ERROR During Deployment Backup and Recovery

Accepted Solution Solved
Reply
Frequent Contributor
Posts: 126
Accepted Solution

ERROR During Deployment Backup and Recovery

Hi ,

 

I am getting below error during backup: - 

 

A problem occurred in executing a "Deployment Backup and Recovery" operation.

 

Operation Status : NOT_STARTED

This was a scheduled backup.

It is recommended to take another clean backup by running sas-backup after recovering from the error situation.

 

Got Exception as follows:

 Backup Errors 

                              Error Entry:

                                                           Status Code: 671

                                                           Name: ERROR_CODE_DEPLOYMENT_AGENT_COMMUNICATION_FAILURE

                                                           Category: GENERAL

                                                           Classification: ERROR

                                                           Date and Time Of Error: 2017-05-28T01_00_00

                                                           Log Name: SASDeploymentBackup9.4.log

                                                           Log File Location: /opt/sas/config/Lev1/Web/Logs/SASServer1_1

                                                           Operation Type: backup

                                                           Originating Tier: xxxxxxxxxxxxxxx

                                                           Message: An error occurred while trying to connect to the host using the SAS Deployment Agent. Please make sure that the agent is running on required hosts. Please refer the "Starting and Stopping the SAS Deployment Agent" chapter of the "System Administration Guide".

                                                           Stack Trace: Primary metadata server is not reachable using SAS Deployment Agent. Primary metadata tier : xxxxxxxxxxxxxxx


Accepted Solutions
Solution
‎05-29-2017 04:44 AM
Trusted Advisor
Posts: 1,141

Re: ERROR During Deployment Backup and Recovery

Hello @japsas100,

 

This error means that one pre-requisite is not working. In this case, it is the SAS deployment agent. For this tool to work as scheduled, you will need to have the SASServer1_1 (plus its dependencies) and the SAS Deployment Agent (on each box of your SAS deployment) to be up and running.

 

Probably the server rebooted and the agents did not started. THe solution is quite simple. SAS provides scripts ready-to-be-scheduled for automatic start of the agents, after a reboot: https://communities.sas.com/t5/tkb/articleprintpage/tkb-id/library/article-id/1448

 

Does it help?

View solution in original post


All Replies
Solution
‎05-29-2017 04:44 AM
Trusted Advisor
Posts: 1,141

Re: ERROR During Deployment Backup and Recovery

Hello @japsas100,

 

This error means that one pre-requisite is not working. In this case, it is the SAS deployment agent. For this tool to work as scheduled, you will need to have the SASServer1_1 (plus its dependencies) and the SAS Deployment Agent (on each box of your SAS deployment) to be up and running.

 

Probably the server rebooted and the agents did not started. THe solution is quite simple. SAS provides scripts ready-to-be-scheduled for automatic start of the agents, after a reboot: https://communities.sas.com/t5/tkb/articleprintpage/tkb-id/library/article-id/1448

 

Does it help?

Frequent Contributor
Posts: 126

Re: ERROR During Deployment Backup and Recovery

I have followed the same steps as per below documentation but when I check the status it return "SAS Deployment Agent directory not found"

 

[root@sastest01 xxxxxxxx]# service sas.deployd status
SAS Deployment Agent directory not found

Trusted Advisor
Posts: 1,141

Re: ERROR During Deployment Backup and Recovery

[ Edited ]

Hello there @japsas100,

 

on the sas.deployd, did you had the opportunity to read the instructions and content? 

 

ON the first lines, there is a definition of a variable, by default:

 

AGENT_PATH=$SASHOME/SASDeploymentAgent/9.4

You can check if it is the right one. Once you do this, repeat the steps to re-deploy the script.

 

Also, please bear in mind the instruction on the link are OS-related. On the sas.deployd file you can find the custom instructions for each OS.

Frequent Contributor
Posts: 126

Re: ERROR During Deployment Backup and Recovery

Yes, I can see AGENT_PATH defined as default. But still, i am getting the same error.

 

#
#*****

AGENT_PATH=$SASHOME/SASDeploymentAgent/9.4

#*****

 

I have repeated the same steps.

Trusted Advisor
Posts: 1,141

Re: ERROR During Deployment Backup and Recovery

It seems as the variable $SASHOME is not being resolved. Try to hardcode this variable. Probably something as:

 

AGENT_PATH=/opt/sas/sashome/SASDeploymentAgent/9.4

Frequent Contributor
Posts: 126

Re: ERROR During Deployment Backup and Recovery

Now agent services has been started Smiley Happy

 

[root@sastest01]# service sas.deployd start
SAS Deployment Agent started successfully

 

Thanks.

 

☑ This topic is SOLVED.

Need further help from the community? Please ask a new question.

Discussion stats
  • 6 replies
  • 295 views
  • 0 likes
  • 2 in conversation