Architecting, installing and maintaining your SAS environment

Can't connect to Oracle

Accepted Solution Solved
Reply
Contributor
Posts: 32
Accepted Solution

Can't connect to Oracle

I'm running  9.3 (TS1M0) on X64_7PRO

When I issue an Oracle libname, I get this message

    libname tz oracle user='agriffin' password=XXXXXXXX path='CEFS2A';

ERROR: The SAS/ACCESS Interface to ORACLE cannot be loaded. ERROR: Image SASORA  found but not loadable..Please make sure Oracle environment is set correctly. Look in the install/Config doc for additional info for your platform.

Other possible reasons - incomplete Oracle client install, 32/64-bit mismatch between Oracle client & SAS, incorrect Oracle client version(Oracle client must match the version picked during post-install process), incompatible sasora for your OS or its attribs don't permit SAS to load it.

I’ve tried the following without success

Removed the quotes as described in Problem Note 46630

Checked I have a 64-bit Oracle by connecting with SQL*Plus. It says connected to Oracle Database 11g Release 11.2.0.3.0 - 64bit Production

Checked my path — the first item is c:\Oracle\product\11.2.0\client_1\bin, which is the correct location of Oracle.

Checked that authenticated users have read and execute rights to the bin folder

I’d like to check that SAS is referring to the correct Oracle client version. How is this done? When an administrator opens sas.dm in C:\Program Files\SASHome\SASDeploymentManager\9.3, it just quits.

Any ideas?

--Adrian


Accepted Solutions
Solution
‎08-20-2013 02:56 PM
Contributor
Posts: 32

Re: Can't connect to Oracle

Everything works fine when the 64-bit Oracle client is installed.  Some checks to do with windows regedit. Make sure that ORACLE_HOME in the registry points to the location of the 64-bit Oracle client. The registry key is HKEY_LOCAL_MACHINE\Software\Oracle. The PATH variable must have the ORACLE_HOME\bin location. 

View solution in original post


All Replies
Super User
Posts: 3,105

Re: Can't connect to Oracle

Some things to check:

1) Are you currently licenced for SAS/ACCESS to Oracle and is it installed? Run PROC SETINIT to check the licence. If you are using EG you can check your SAS server properties to confirm the products installed/licenced.

2) Are you using 64-bit SAS? You must be using this to be able to connect via 64 bit SQL*Net.


Contributor
Posts: 32

Re: Can't connect to Oracle

Yes, I have confirmed that the Oracle engine is licensed and installed. I am using 64-bit SAS.

Super Contributor
Posts: 578

Re: Can't connect to Oracle

Having the oracle engine licensed and installed is perhaps not the same as having the SAS/Access to Oracle connector licensed and installed. true?

Super User
Posts: 3,105

Re: Can't connect to Oracle

I am assuming since SQL Plus was used to connect to Oracle that it was done on the same PC as SAS so the Oracle side of things is working fine - is that correct Adrian?

Contributor
Posts: 32

Re: Can't connect to Oracle

It seems I have the 32-bit Oracle client on my machine. The 64-bit shown when I connected with SQL Plus referred to the version on the server.  But I'll keep this thread open until I get the 64-bit client installed and check that that works.

Solution
‎08-20-2013 02:56 PM
Contributor
Posts: 32

Re: Can't connect to Oracle

Everything works fine when the 64-bit Oracle client is installed.  Some checks to do with windows regedit. Make sure that ORACLE_HOME in the registry points to the location of the 64-bit Oracle client. The registry key is HKEY_LOCAL_MACHINE\Software\Oracle. The PATH variable must have the ORACLE_HOME\bin location. 

Super User
Posts: 3,105

Re: Can't connect to Oracle

Looks like you have checked out most of the relevant SAS Notes as well and confirmed SQL Plus is working OK from the same PC (hence your tnsnames.ora config file must be OK) so maybe its time to create a SAS Support track if you haven't done so already....

☑ This topic is SOLVED.

Need further help from the community? Please ask a new question.

Discussion stats
  • 7 replies
  • 6886 views
  • 0 likes
  • 3 in conversation