Architecting, installing and maintaining your SAS environment

BI Platform with Pooled Workspace Server issues

Accepted Solution Solved
Reply
Contributor
Posts: 47
Accepted Solution

BI Platform with Pooled Workspace Server issues

Hi All

 

We have a Clustered Metadata server (3 VM Nodes) running on our BI Platform (SAS9.4M2 - quite troublesome!) and a few days ago started getting this problem when trying to validate our Pooled Workspace server:

 

[24/06/16 11:55] INFO: Starting extended validation for Pooled Workspace server (level 1) - Making a connection
[24/06/16 11:55] SEVERE: Insufficient information provided for a connection to the metadata server.
[24/06/16 11:55] SEVERE: Access denied.
[24/06/16 11:55] SEVERE: The application could not log on to the server "mysasserver:8702". The user ID "mylogin@!*(generatedpassworddomain)*!" or the password is incorrect.

 

So even though our Metadata Servers are up and running, we are now suddenly unable to validate our Pooled Workspace Server in Management Console.

 

What would be a suitable fix - without going about it the Trial and Error method (try this, and then try that, etc etc...)? Has anyone experienced and fixed this before?

 

I have logged a call with SAS Support but it's been a few days now and we are getting nowhere.

Any help will be much appreciated.

Spoiler
 

 


Accepted Solutions
Solution
‎06-27-2016 04:34 AM
Contributor
Posts: 47

Re: BI Platform with Pooled Workspace Server issues

Posted in reply to JuanS_OCS

Hi Juan

 

Since I could not figure out how to resolve this on Friday afternoon, I decided to do a little diagnostic check in MC and validate all our Metadata Servers in our cluster as well as all the ObjectSpawners.

 

It turned out that the 1st Node in our Metadata Cluster could not be validated, even though the active Metadata Server was Node 3, and fully functional. Somehow this issue then had a knock on effect whereby  a large number of services could not be validated. I had to restart the Metadata server Node1 in our Metadata Server cluster and the problem was resolved.

 

Smiley Very Happy

View solution in original post


All Replies
Trusted Advisor
Posts: 1,312

Re: BI Platform with Pooled Workspace Server issues

Hi, 

 

did you already executed a restart/refresh the Object Spawner for that PooledWorkspace Server? And can you validate the StoredProcess Server? Are both under the same SASApp?

 

The best thing you can do is to increment the logging level to DEBUG on your PooledWorkspace server, refresh the object spawner for this PWS and analyse the new logs. This should give you the information you require.

 

Hope it helps.

Best regards,

Juan

 

 

Solution
‎06-27-2016 04:34 AM
Contributor
Posts: 47

Re: BI Platform with Pooled Workspace Server issues

Posted in reply to JuanS_OCS

Hi Juan

 

Since I could not figure out how to resolve this on Friday afternoon, I decided to do a little diagnostic check in MC and validate all our Metadata Servers in our cluster as well as all the ObjectSpawners.

 

It turned out that the 1st Node in our Metadata Cluster could not be validated, even though the active Metadata Server was Node 3, and fully functional. Somehow this issue then had a knock on effect whereby  a large number of services could not be validated. I had to restart the Metadata server Node1 in our Metadata Server cluster and the problem was resolved.

 

Smiley Very Happy

☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 2 replies
  • 503 views
  • 2 likes
  • 2 in conversation