Architecting, installing and maintaining your SAS environment

After Applyting SAS AD Integration primpd option local server users are not working

Reply
Contributor
Posts: 63

After Applyting SAS AD Integration primpd option local server users are not working

Dear All,

 

We are not able to authenticate local server users after defining SAS AD Integration primpd option.

 

Regards,

Kaushal

SAS Employee
Posts: 242

Re: After Applyting SAS AD Integration primpd option local server users are not working

@kaushalsolanki,

 

If you are talking about Direct LDAP Authentication on the metadata server, that's correct, you have to use this user ID format:

 

user-ID@host

 

It this case the metadata server sends the credentials to its host.

Contributor
Posts: 63

Re: After Applyting SAS AD Integration primpd option local server users are not working

@alexal,

 

Thank you for the reply.

 

We tried with user-id@host but still it is going to AD only for user credential validation.

 

For reference SASV9_usermods.cfg parameters are as mention below.

 

-set AD_HOST example.ad

-set AD_PORT 389

 

-authpd ADIR:example.ad

-primpd  example.ad

 

Regards,

Kaushal

SAS Employee
Posts: 242

Re: After Applyting SAS AD Integration primpd option local server users are not working

@kaushalsolanki,

 

I would like to review what happens in the metadata log when you use user-ID@host.

Highlighted
Contributor
Posts: 63

Re: After Applyting SAS AD Integration primpd option local server users are not working

@alexal,

 

Have checked the Metadata logs when i am trying user-ID@host, it is giving me warning as given below.

 

"New client connection rejected from server port 8562 for user sas@host for APPNAME=SAS Management Console"

 

Regards,

Kaushal 

SAS Employee
Posts: 242

Re: After Applyting SAS AD Integration primpd option local server users are not working

@kaushalsolanki,

 

Please increase debug level for Audit.Authentication by adding this to /<SASConfig>/Lev<X>/SASMeta/MetadataServer/logconfig.xml:

 

<logger name="Audit.Authentication">
<level value="Trace"/>
</logger>

Restart the metadata server, repeat the problem and show me the log file.

Ask a Question
Discussion stats
  • 5 replies
  • 138 views
  • 0 likes
  • 2 in conversation