Architecting, installing and maintaining your SAS environment

APM - Opening up history

Reply
Frequent Contributor
Posts: 75

APM - Opening up history

Hi,

We're running SAS 9.3 (TS1M2), Rev. 930_12w41, on Windows Server 2008 64 bit R2 SP1.  It's been running since October 2013.

Audit Performance Management has been installed, and is running, however it doesn't show more than one weeks worth of data.

How can I change this such that it shows more than just one weeks worth of data?

When I look at the following directory on the compute server:

F:\SAS\Config\Lev1\SASApp\WorkspaceServer\PerfLogs

I can see logs going back more than just one week, yet when I look at WorkspaceTopUsers.html in APM only has the data for the past week, so I don't think it's an issue of the logs disappearing or not having them to begin with.

I expect there's a number that I can update and as a result it will show more history?

Thanks.

Super Contributor
Posts: 356

Re: APM - Opening up history

Modify the job that creates the report, should be called in  artifactTopTen.sas  Ebiapm92\SASEnvironment\SASCode\Jobs\usageReports in particular the  &weekSubset

data work.temp /view=work.temp;
  set artifact.artifactusagedetails;

  /*
   *  Select OPEN rows.
   */

  where type="OPEN";

  /*
   *  Include any subsetting defined in the defaults.
   */
  
  &weekSubset.;
 
run;

Or create a new job based on the above for more than a week

Barry

Frequent Contributor
Posts: 75

Re: APM - Opening up history

Hi Barry,

Thanks for the lead.

Doesn't look to be a simple enhancement, I think I need to trace backwards somehow to figure out where &weekSubset. comes from.

Super Contributor
Posts: 356

Re: APM - Opening up history

You may be able to change the value in artifactReportNumWeeks macro found in Ebiapm92\SASEnvironment\SASMacro.  This macro is called from the job I mentioned above

and then weekSubset is set in artifactreportdefaults.sas

%let weekSubset=where also datetime>dhms(intnx('week',datepart(datetime()),-&numweeks.,'S'),0,0,0);

Barry

Frequent Contributor
Posts: 75

Re: APM - Opening up history

I've finally gotten the time to look at this again.

I think I've found it.

This is what I did:

* Looked at some code in the location Barry suggested, for our installation it was F:\SAS\Config\APM93\SASEnvironment\SASCode\Jobs\usageReports\artifactTopTen.sas

* Observe there is a call to %artifactReportSubSet; near the top of the code, it was two lines above the reference to &numWeeks.

* Looked in the Macro directory, for us it was F:\SAS\Config\APM93\SASEnvironment\SASMacro\artifactreportsubset.sas, chose the job which looked to have the macro in it (pretty well named I'd say)

* Find that the contents has all the magic figures I'm interested in

I'm more comfortable changing the figure in one location, rather than hard coding it in individual jobs.

Hopefully if anyone else has this issue, this might help.

I think I was not following Barry very well because it looks as though we've on 9.3 and he was on 9.2.

Ask a Question
Discussion stats
  • 4 replies
  • 514 views
  • 3 likes
  • 2 in conversation