Architecting, installing and maintaining your SAS environment

A problem when deploying sas on Linux

Accepted Solution Solved
Reply
Contributor
Posts: 65
Accepted Solution

A problem when deploying sas on Linux

Hi, guys

 

I'm trying deploy sas on linux, there is a tricky problem. I can't understand. Here is the Log:

 

第 3 阶段(共 14 个阶段)的第 1 步(共 1 步): Initialize “SAS Metadata Server Configuration”

第 3 阶段(共 14 个阶段)的第 1 步(共 1 步): Configure “SAS Metadata Server Configuration”pathName=/data/SASHome/SASVersionedJarRepository/eclipse/plugins/sas.oma.mgmt_904300.0.0.20150204190000_v940m3/sas.oma.mgmt.jar
pathName=/data/SASHome/SASVersionedJarRepository/eclipse/plugins/sas.oma.mgmt_904000.0.0.20130522190000_v940/sas.oma.mgmt.jar
pathName=/data/SASHome/SASVersionedJarRepository/eclipse/plugins/sas.svc.core.signed_20160520_904300.7.0.20150513190000_v940m3/sas.svc.core.jar
pathName=/data/SASHome/SASVersionedJarRepository/eclipse/plugins/sas.svc.core_904201.1.0.20150618123016_v940m2f/sas.svc.core.jar
pathName=/data/SASHome/SASVersionedJarRepository/eclipse/plugins/sas.svc.core_904300.7.0.20150513190000_v940m3/sas.svc.core.jar
pathName=/data/SASHome/SASVersionedJarRepository/eclipse/plugins/sas.svc.core_904200.0.0.20140723190000_v940m2/sas.svc.core.jar
pathName=/data/SASHome/SASVersionedJarRepository/eclipse/plugins/sas.svc.core_904301.8.0.20160126090816_v940m3f/sas.svc.core.jar
............
................................................................................
........pathName=/data/SASHome/SASVersionedJarRepository/eclipse/plugins/sas.oma.mgmt_904300.0.0.20150204190000_v940m3/sas.oma.mgmt.jar
pathName=/data/SASHome/SASVersionedJarRepository/eclipse/plugins/sas.oma.mgmt_904000.0.0.20130522190000_v940/sas.oma.mgmt.jar
pathName=/data/SASHome/SASVersionedJarRepository/eclipse/plugins/sas.svc.core.signed_20160520_904300.7.0.20150513190000_v940m3/sas.svc.core.jar
pathName=/data/SASHome/SASVersionedJarRepository/eclipse/plugins/sas.svc.core_904201.1.0.20150618123016_v940m2f/sas.svc.core.jar
pathName=/data/SASHome/SASVersionedJarRepository/eclipse/plugins/sas.svc.core_904300.7.0.20150513190000_v940m3/sas.svc.core.jar
pathName=/data/SASHome/SASVersionedJarRepository/eclipse/plugins/sas.svc.core_904200.0.0.20140723190000_v940m2/sas.svc.core.jar
pathName=/data/SASHome/SASVersionedJarRepository/eclipse/plugins/sas.svc.core_904301.8.0.20160126090816_v940m3f/sas.svc.core.jar
..

配置 SAS Metadata Server Configuration 时遇到以下问题:

未检测到 MetadataServer 监听程序。主机: atfrd0002。端口:
8561。

配置脚本:

/data/SASHome/SASFoundation/9.4/misc/base/sasconf/metadatasrv/config/metadatasrv_config.xml

详细信息,请参见以下位置的日志文件:

/data/SASConfig/Lev1/Logs/Configure/metadatasrv_configureMetadata_2016-06-16-12.05.37.log
在通过以下方式忽略该错误前,您应确认该配置错误不会导致其他产品出错:
对以下后续问题回答是或全是。若选择是或全是,
您将不能重试任何忽略的步骤,除非先完全取消配置,然后再重新配置。
若不确定,请在继续部署之前与
SAS 技术支持人员联系获取相关指导。

 

The problem is: it cannot detect the listenning program on port 8561. If I use the command: "./MetadataServer.sh start" to start the Metadata Server, and I retry to deploy, and it told the port is occupied! And I use command "./MetadataServer.sh stop" to stop the Metadata Server, then I retry to deploy, and it told me there is no listenning program on port 8561.

 

How should I do?


Accepted Solutions
Solution
‎08-23-2016 10:47 PM
Super User
Posts: 6,936

Re: A problem when deploying sas on Linux

Open up a call with SAS Technical Support; they're best for this kind of installation problems.

It seems that the start of the Metadata Server fails when done from the deployment wizard.

---------------------------------------------------------------------------------------------
Maxims of Maximally Efficient SAS Programmers

View solution in original post


All Replies
Solution
‎08-23-2016 10:47 PM
Super User
Posts: 6,936

Re: A problem when deploying sas on Linux

Open up a call with SAS Technical Support; they're best for this kind of installation problems.

It seems that the start of the Metadata Server fails when done from the deployment wizard.

---------------------------------------------------------------------------------------------
Maxims of Maximally Efficient SAS Programmers
Contributor
Posts: 65

Re: A problem when deploying sas on Linux

Thanks, I will call  Technical Support.

Super User
Posts: 6,936

Re: A problem when deploying sas on Linux

PS I see a lot of Chinese(?) characters in your post. If that was not intended, consider copy/pasting your original text to notepad and then recopy it before posting here. There might be useful information in there.

 

---------------------------------------------------------------------------------------------
Maxims of Maximally Efficient SAS Programmers
SAS Super FREQ
Posts: 291

Re: A problem when deploying sas on Linux

Hi,

 

as Kurt mentioned earlier, Tech Sup would be a great way to go.

 

It is hard to see all that's going on due to the different language in the log.

It looks like you are installing SAS 9.4M3.

 

You mentioned that you are deploying SAS on Linux, and also mentioned that you try to start the Metadata Server?

Does this mean that SAS has been installed, is configured, and you are now trying to run SAS, getting an error?

I am a bit fuzzy about where in the deployment process you are.

 

Could you please provide the complete error message?

Did you verify that the port 8561 is available and not used by any other process?

 

Thanks

Anja

 

Contributor
Posts: 65

Re: A problem when deploying sas on Linux

Thankyou, after I retry many times, it worked.

☑ This topic is SOLVED.

Need further help from the community? Please ask a new question.

Discussion stats
  • 5 replies
  • 413 views
  • 1 like
  • 3 in conversation