/opt/sas/viya/config/etc/sysconfig/sas-javaesntl/sas-java does not exist !

Accepted Solution Solved
Reply
Frequent Contributor
Posts: 96
Accepted Solution

/opt/sas/viya/config/etc/sysconfig/sas-javaesntl/sas-java does not exist !

Hi,

 

I am upgrading sas viya from 3.2 to 3.3 and I am getting this error as:

 

fatal: [deployTarget]: FAILED! => {"changed": false, "failed": true, "msg": "Destination /opt/sas/viya/config/etc/sysconfig/sas-javaesntl/sas-java does not exist !", "rc": 257}

 

But, I had set the sas_install_java= true in the vars.yml and Java is getting installed as well. But, still the deployment is failing. Does any one can help on this?

 

Thanks!!


Accepted Solutions
Solution
‎03-05-2018 02:58 AM
SAS Employee
Posts: 524

Re: /opt/sas/viya/config/etc/sysconfig/sas-javaesntl/sas-java does not exist !

@AmitSri,

 

Run this command:

 

ansible -i inventory.ini all -m shell -a 'sudo rpm -e sas-javaesntl'

After that run deploy-cleanup.yml  and try to install SAS Viya 3.3 once again.

View solution in original post


All Replies
SAS Employee
Posts: 524

Re: /opt/sas/viya/config/etc/sysconfig/sas-javaesntl/sas-java does not exist !

@AmitSri,

 

This is the first upgrade attempt? If not, how was the cleanup performed between them? Please run this command and show me the output:

 

$ ansible -i inventory.ini all -m shell -a 'rpm -vV sas-javaesntl'

If you deleted / moved / remounted /opt/sas/viya without uninstalling the packages, Ansible won't attempt to reinstall them because it thinks they're already installed.

Frequent Contributor
Posts: 96

Re: /opt/sas/viya/config/etc/sysconfig/sas-javaesntl/sas-java does not exist !

Hi Alex, I had run ansible-playbook deploy-cleanup.yml before installing it.

Please find the output that you asked for:
[root@gspdsv04 sas_viya_playbook]# ansible -i inventory.ini all -m shell -a 'rpm -vV sas-javaesntl'
[WARNING]: Consider using yum, dnf or zypper module rather than running rpm

deployTarget | FAILED | rc=1 >>
......... /etc/sysconfig/sas/sas-java-services-viya
......... /etc/sysconfig/sas/sas-java-viya
missing /opt/sas/viya/config/etc/sysconfig/sas-javaesntl
missing c /opt/sas/viya/config/etc/sysconfig/sas-javaesntl/sas-java
missing c /opt/sas/viya/config/etc/sysconfig/sas-javaesntl/sas-java-services
Thanks!!
Solution
‎03-05-2018 02:58 AM
SAS Employee
Posts: 524

Re: /opt/sas/viya/config/etc/sysconfig/sas-javaesntl/sas-java does not exist !

@AmitSri,

 

Run this command:

 

ansible -i inventory.ini all -m shell -a 'sudo rpm -e sas-javaesntl'

After that run deploy-cleanup.yml  and try to install SAS Viya 3.3 once again.

Frequent Contributor
Posts: 96

Re: /opt/sas/viya/config/etc/sysconfig/sas-javaesntl/sas-java does not exist !

Hi Alex,

Thank you so much. This made my deployment successfully. Viya is now upgraded to 3.3. Thanks again!!
SAS Employee
Posts: 524

Re: /opt/sas/viya/config/etc/sysconfig/sas-javaesntl/sas-java does not exist !

@AmitSri,

 

You are welcome! I'm glad the problem has been resolved.

☑ This topic is solved.

Need further help from the community? Please ask a new question.

Discussion stats
  • 5 replies
  • 418 views
  • 1 like
  • 2 in conversation