
SAS Enterprise Guide 8.1 – New Features 
 
 

A lot of what we’ve changed in SAS Enterprise Guide (EG) 8.1 has come directly from our many users 
over many years. John Maxwell once said that change is inevitable, and growth is optional. The EG 
team knows that we’ve “moved your cheese” so we are very excited to hear your candid and differing 
reactions to what we’ve changed and introduced.  
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Finding Your Way Around 
When you first open EG8.1, it seems very barren - intentionally so! EG’s layout is all about maximizing 
the space and efficiency needed to code and build process flows, while leaving ample room to browse 
and access the full context of your files or project. The UI is divided into five areas: 

Navigation Bar and Panes - Contains different panes like the Project, Servers, Tasks panes to assist 
you while working on your project or program. 

Workspace - The main area to work directly within your files. You can open as many tabs as you like, 
side by side vertically and horizontally. 

Status Bar - Information about the files you edit and submit. 

Tools Area - You can display different panes below the workspace region for viewing status. Tools 
panes can also be moved around for more vertical space. 

Profile Connection Indicator– indicates which profile you are working in 

 

  



About the Navigation Panes 
Most of the panes are trees that contain folders and files. You can do many things from them: 

• Create, delete, and rename files and folders. 
• Move files and folders with drag and drop. 
• Use the context menu to explore all options. 

Tip: Drag and drop these panes and use the Layout Guide to help you position them where you like 
them.  

Open Items At a glance you can see a list of your currently opened files. You can also rearrange the 
files which will also rearrange the tabs.  

Servers contains a list of servers based on the selected 
profile. The profile that is currently active is shown in the 
top right of the EG application.  

 

The active server has a check mark next to it. 

 

 

 

Tasks contain a list predefined tasks, which are point-
and-click user interfaces that guide you through a 
process. 

 

 

 

 

 

 



Project Used to manage all the files in a project and 
process flow allowing you easy access to all files you 
need in one place, so you don’t have to keep flipping 
back and forth to Servers or SAS Folders. 

 

 

 

 

SAS Folders are folders and files defined in the SAS 
Metadata Server and can be used to provide a central 
location for your stored processes, information maps, and 
projects so that they can be shared with other SAS 
applications. SAS folders can also contain content that is 
not in the SAS Metadata Server, such as data files. You can 
use SAS folders to add items to your project or to open a 
different project. 

Prompt Manager contains a list of your prompts.  

Start Page 
By default, the Start Page opens whenever you start EG. It has some helpful topics should you need 
them, such as quick links to opening a new program or project, learning links and quick links to help 
you should you experience issues. Once you start opening files the right side now displays these files 
in a Recent list. You can also pin files. If you find the Start Page useful, you can keep it up. If you 
accidently close it, you can bring it back by going to View > Start Page.  

On the other hand, if you don’t want to see the Start Page whenever you open EG you can go 
Options > Start Up and uncheck Show Start Page. By the way, while you are in Options check out 
the other items you can automatically open (or not) at start up. 

  



Working with a Project 
One of the biggest changes that we have made to EG, that we are quite proud of, is that you decide if 
you want to work with a project or not. This means that you can now use it as a tool to open and work 
on single files or use it to open a project (think of a folder) and work with all the files there as a group. 
By default, EG 8.1 does not start up with a project open. By default, EG 8.1 does not start up with a 
project open.  

To create a new project: 

• Go to the File menu, click New, then click Project, or  
• Click the New icon  on the top toolbar, then click Project, or 
• Go to the Start page and click New project, or 
• From the Project pane, click New project 

To close a project: 

• From the Project pane, click the More Actions icon  and then click Close project 
• Go to the File menu, click Close project 

If you have no interest in projects at all and want to declutter your 
environment, you can close the Project pane. Click Hide or from the 
View menu, uncheck Project. You can then bring it back by 
checking it later. 

 

Items That Don’t Require a Project 
For EG8.1, these are the items that do not require a project. They can be opened and edited in a 
‘project-less’ environment. We plan on adding more items, such as tasks, to the list in subsequent 
releases.  

• Programs 
• Data 
• OLAP Cubes 
• SAS Report Results 
• SAS Visual Analytics Reports 
• Logs  

 



Automatically Adding Items to a Project 
One of the things that previous versions of EG did was to automatically add any item you opened to a 
project. You had no choice. Some users loved this; other users not so much. Now you have the choice. 
By default, the option to add items to a project is set to ON. This was deliberate for those that loved 
this feature. Take a test drive, just to make sure.  

1. Create a new project. 

If you open an existing project, make sure that you use a copy of any production projects.  

2. Open a program.  
• Go to the File menu, click New, then click Program, or  
• Click the New icon  on the top toolbar, then click Program, or 
• Go to the Start page and click New program, or 
• Press F4 

Notice that the file is added to a project as an “embedded” file, just like it did in previous versions. 
The only small difference is there is a small triangle on the program icon to indicate 
that it is an ‘embedded’ file as opposed to a referenced file. A referenced file is a file that has been 
saved externally to the project and then added. An embedded file does not exist externally to the 
project.   

Now let’s continue working with a project but turn off automatically adding items to it.  

1. Go to Tools > Options > Project and Process Flows. 
2. Uncheck When an item is opened automatically add to the project. 
3. Click OK. 
4. Open a new program. Notice that it does not get added to the project.  

Perhaps after a while you decide that you do want to add that program to the project after all. 

5. Right-click on the program’s tab and select Add to Project.  

The program is manually added to the project. You can also manually add items that are not even 
opened.  



1. Navigate to the Servers pane, and right click on a file – could be a data set or a file on your server. 
There are three options: 

• Open – opens the file in a tab. 
• Open and add to project – opens the file and adds it to a project. 
• Add to project – directly adds a file to the project, as a referenced file, without opening it in a tab. 

Pretty cool. Now you can add the files you want; when you want.  

  



Side-by-Side Editing and Viewing 
Most modern editors support viewing multiple files at once, allowing you to switch between open 
files through some kind of tab-based interface. EG 8.1 has joined that group. You can open as many 
tabs as you like side-by-side, vertically and horizontally. In addition, within a Program, you can 
rearrange the secondary tabs (Code, Log, Results, Output Data). 

There are various ways to rearrange tabs.  

• From the View menu, use the Apply tab layout and Program tab presets to layout tabs.  
• Drag a tab, and use the Layout Guide to help you position the tab. 

• Right-click on a tab and select New horizontal tab group or New vertical tab group options 

Running Multiple Items without Locking the UI 
Run a project or, if you are not using a project, run more than one program. Even while one or more 
programs are running you can work in other programs. You will see several icons display in various 
places such as the tab itself or next to the file in the Project or Open Items panes.  

Program is queued in the order of submission. 

 

Program is in the process of being submitted. 

 

Status icons will show you, at a quick glance, if your program ran with errors 
or warnings. 

Use the Submission Status (formerly known as the Tasks Status) tool to help you manage all 
submissions. You can see the status of various submissions and cancel them. While we have tried to 
improve the cancelling experience within EG, we still must wait until SAS reaches a place where it can 
gracefully cancel.  



Working with Tasks 
Tasks are very popular – especially the Query Builder and Import tasks. By default, these two tasks 
have been favorited for you so that they are quickly accessible. While Tasks are no longer available 
from the menu bar, they are available from the Tasks pane, which you can conveniently move to any 
location or even float it on a different monitor. In 8.1 you will still need a project to work with tasks. 
To be upfront, we know that this is not the best user experience. In 8.2 we plan to support working 
with Tasks without requiring a project, but we could not get that into 8.1 due to all the architectural 
changes that were required. 

If you have SAS Studio Enterprise or SAS Studio Single User versions installed, you can access the 
hundreds of SAS Studio tasks that have been written for you. Go to Options > Tasks > SAS Studio 
Integration and check Display SAS Studio tasks. For now, only the built-in SAS Studio are available. 
Being able to access your custom SAS Studio tasks is also planned for the next version. 

Locked Data Sets 
Data sets are no longer locked. Run a program that creates > 3 datasets. Lay them out so that you can 
see all the created datasets at once.  - see what happens when you change the data and resubmit. 
After 3 minutes of inactivity any open data will be unlocked. This is an option that can be changed 
Options > Data > Performance then change how many minutes you want before Unlock open data 
after inactivity. 

Drag and Drop Data Set Names and Variables into a 
Program 
Ever mistyped variable names in your code? Now you can drag the variables into your program and 
avoid errors in the log. Navigate to a data set. If you don’t have one you can always use the sample 
ones provided. From the Servers pane navigate to Servers > Local > Libraries > SASHELP. With a 
program open, click and drag a data set name into the program.  

Drag any columns into a program as well. No need to type and less error prone.  



Notifications 
We’ve made improvements in error handling by providing better messaging. At times messages are 
important but not important enough to stop you working by displaying annoying dialogs. For 
example, if you open a project that was saved to a different profile you’ll see a notification display. 
Some notifications will also have actions to help you out. 

Knowing the Status of Submissions 
Check out the Submission Status tool. It used to be called Tasks Status, but we renamed it to be in 
line with SAS Studio and quite frankly many users did not know it existed. Perhaps there were too 
many ‘tasks names’! Go to View > Submission Status or click the Submission icon in the status bar. 
The status bar will also show you if have any files that ran with errors or warnings.  

 

You can filter by various options, cancel submitting or queued programs, clear the list manually or 
have the list automatically cleared for you. 

  



Rearranging Your Tabs & Panes  
Enterprise Guide offers a myriad of ways to arrange the panes and tabs that 
you work with. A handy Layout Guide helps you do the heavy loading.  

1. Open a new program and use the Layout Guide to rearrange your 
program’s secondary tabs.  

 

2. Float a tab. Once floated you can quickly dock it again. 

 

3. Move the Task pane to the bottom of the work area. 
• There are some preset layouts for you to explore in View > Apply tab layout and View | 

Program tab layouts. When a program preset layout is selected it applies to the active program 
and any subsequent programs you open.  

• When working with your various window layouts you sometimes will get to the point where you 
just want to start over. Go to View > Restore default layout. 

Themes 
What? You don’t like a light theme? Perhaps you prefer to work in the dark? Just kidding. Want to 
check out Ignite, our dark theme? Go to Options > General and under the Visual Experience section 
choose Ignite as the color theme.  This is one of those areas that is still under development so not all 
EG has been themed yet. But you get the idea. 

Search 
Searching for an item in a project used to be in the upper-right corner. 

It is now a Search panel that you can toggle on or off. Not only can you quickly search for items in a 
project, but also the items in the Open Files pane. You can launch it in two ways.  

• Click the Search icon in the top toolbar area 
• Go to View > Search. 



We would love to hear what else you expect to search on. We have ideas on how to expand the 
search experience, but we prefer to hear from you. 
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