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Agenda

ÅLitt om versjonskontroll generelt

ÅLitt om Git

ÅLitt om versjonskontroll fra EG – intern/ekstern

ÅEksempler/demoer av noen usecases

ÅSpørsmål / diskusjon



Copyright  © SAS Inst itute  Inc.  A l l  r ights reserved.

Versjonskontrollsystem

ÅHolder orden på de forskjellige versjonene av datafiler

ÅGamle versjoner lagres og man kan hente de fram

ÅMan kan sammenligne/se forskjeller mellom versjoner

ÅStøtter ofte sammenfletting av versjoner (merging)

ÅStøtter ofte «branching» - parallelle utviklingsløp.

CVS(Concurrent Version System)-> Subversion(SVN) -> Git
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Git
Versjonskontrollsystem

ÅDistribuert – støtter desentralisert arbeidsflyt. Praktisk konsekvens i 
forhold til SVN/CVS er at commiti Git er commit, pullog pushsiden man 
må eksplisitt synkronisere med sentralt repository.

ÅGit har et staging area hvor endringer mellomlagres og kan sjekkes før de 
«commit»-es.

ÅIkke mappehierarki-basert – Undermapper er ikke egne repositories som i 
SVN og CVS – historikk bevares dersom filer flyttes fra en mappe til en 
annen

ÅSjekksum (sha1) av innhold

ÅBedre til merge enn til branch
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Git
Versjonskontrollsystem

Staging Area

ÅMan kan ganske raskt «stage»
noen av filene

ÅMan kan også «stage» deler av
en modifisert fil –
typiske i flere omganger dersom
det er flere endringer gjort i 
filen som man ønsker
å «commit»-e som separate
operasjoner

Arbeidsområde 
(filsystem)

Staging-område

Repository

Add

Commit
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Git
Versjonskontrollsystem

Branching og Merging

Master

Utvikling

Eksperimentell
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Git
Versjonskontrollsystem

Distribuert 

Enkelt og sentralisert som SVN

Delt «repository»

Utvikler Utvikler Utvikler
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Git
Versjonskontrollsystem

Distribuert 

Med f.eks. GitHub

Offisielt «repository»

Utvikler
privat

Utvikler
privat

Utvikler
public

Utvikler
public

Integrasjonleder



Copyright  © SAS Inst itute  Inc.  A l l  r ights reserved.

Versjonskontroll i EG

ÅEG har en intern versjonskontroll for «embedded» SAS programmer
ÅVersjonshistorikken lagres internt i EG prosjektfilen (.egp)

ÅBruker Git bak kulissene hvor Git repositoriet er innbakt i .egp filen

ÅSAS programmer som brukes i et EG prosjekt kan lagres eksternt for 
prosjektet med en relativ sti/path (settes i properties til EG prosjektet)
ÅMan kan bruke eksterne versjonskontrollsystemer som SVN, CSV eller Git for å 

ha versjonshistorikk på disse – og på selve EG prosjektfilen (.egp)

ÅFør EG8.2 så bruker man til dels versjonskontrollklienter utenfor EG, men man 
kan gjør commitfra inne i EG 7.1x mot et eksisterende lokalt Git repository.

ÅI EG 8.2 kom det en tettere integrasjon mot Git hvor man kan gjøre 
«commit», «pull», «fetch», «merge», «push», «clone», «branch» i Git fra 
EG grensesnittet.



Copyright  © SAS Inst itute  Inc.  A l l  r ights reserved.

Versjonskontroll i EG
Intern versjonering

ÅI EG 8.2  konfigureres dette under Tools->Options:
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Versjonskontroll i EG
Intern versjonering

ÅI EG 8.2  når man har åpen en «embedded» kodenode:
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Versjonskontroll i EG
Intern versjonering

ÅChange

ÅViser endringer som er gjort i programnoden siden forrige «commit».

ÅCommit

ÅLagre den nåværende koden som en ny versjon

ÅHistory

ÅSe historikk over forskjellige versjon

ÅSammenligne forskjellige versjoner

ÅSe hvilken bruker har skrevet hvilke linjer i programmet (blame)

ÅRevertere til tidligere versjoner
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Versjonskontroll i EG
Intern versjonering

ÅTillater ikke at program i kodenoder deles mellom EG-prosjekter (fordi de er 
«embedded» i EG prosjektet)

ÅHar ikke noe versjonering av selve EG prosjektet og dermed heller ikke av noder 
som ikke er kodenoder.

ÅFordrer at kun en utvikler jobber på samme EG-prosjekt samtidig. 

ÅKjapt, enkelt og intuitivt

ÅMest effektivt sammen med et kildekodeversjoneringssystem som støtter 
«lock» av filer - som SVN eller Git-lsf tillegget til Git. Da kan en utvikler låse EG 
prosjektet mens han jobber med det, når han er ferdig sjekker han in EG 
prosjektet (som da har intern historikk) og opphever låsen slik at neste utvikler 
kan jobbe med prosjektet (og se historikken som forrige utvikler genererte)
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Versjoneringi EG
Ekstern versjonering

ÅMan lagrer kodenoder som .sas filer utenfor EG-prosjektet – tilgjengelig 
over filsystemet fra klienten. (Ikke på SAS serveren – SASApp -> Files !)

ÅBruk relativ sti
ÅSettes på posjektegenskaper

ÅI prinsippet kan ethvert versjonskontrolsystem brukes på disse eksterne 
filene, men…

ÅSiden den interne versjoneringen er basert på Git så støtter EG 7.15 også 
«commit» og «revert» fra EG GUI-et mot et lokalt Git repository (som da 
må settes opp av et eksternt verktøy). Man lagrer filer i repositoryet og 
«commit»-er dem. Man kan ikke «commit»-e EG prosjektfiler fra EG 7.15

ÅEG 8.2 har en tettere integrasjon mot Git med mulighet for Branching og 
kloning fra «remote repositories» over https. Man kan også «commit»-e 
alle typer filer (datafiler, EG-prosjektfilen mm)
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Innstillinger i EG 8.2
Git Repositories

ÅGit Repositories (   ) panelet skal vises som standard, 
men kan aktiviseres med View->Git Repositories
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Innstillinger i EG 8.2
Git Repositories

ÅMan må opprette en profil hvor man angir brukernavn/passord og e-
postadresse for den Git forbindelsen man vil bruke. Man kan angi flere 
profiler om man har flere Git servere/kontoer man vil bruke.

ÅDette gjøres under Tools->Manage Git connections
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Innstillinger i EG 8.2
Git Repositories

ÅFor å bruke et Git repository så må vi klone det til et lokalt repository på 
lokalt tilgjengelig filsystem

ÅKloning vil si at alle filene i repositoriet på Git serveren kopieres til en 
folder som er tilgjengelig på vårt lokale filsystem

ÅDersom man allerede har klonet et slikt repository med andre verktøy 
(f.eks. Git Extenstions) så kan man legge det til direkte i EG.

ÅMan åpner så filene i EG på vanlig måte, redigerer dem og lagrer 
endringene til filsystemet. Så kan man sjekke inn endringene i lokalt 
repository med commit. 

ÅLokale endringer er ikke synlige for andre med mindre man «push»-er 
endringene til repositoriet på Git-serveren.



Copyright  © SAS Inst itute  Inc.  A l l  r ights reserved.

Repositorypå GitHub
Cloningfra an existingGitHubrepository

ÅPå «Git Repositories»-panel så klikk på «Clone»-ikonet

ÅLegg til URL til prosjektet, f.eks.: 
https://github.com/TomArneOrthe/Source_control_with_saseg

ÅLegg til en lokal folder der klonen skal ligge

ÅVelg profil som inneholder brukernavn etc til Git-serveren

https://github.com/TomArneOrthe/Source_control_with_saseg
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Lag et nytt EG prosjekt

ÅPå «Git Repositories»-panelet så skal «Current Repositories» settes til 
dette nye repositoriet man nettopp har klonet.

ÅBruke File->Open for å åpne EG-prosjektet NetflixHistory81 i vår lokale 
folder

ÅVi vil lagre en 8.2 versjon av dette så velg File->Save «NetflixHistory81» as 
og gi den nye filen navnet «NetflixHistory82».

ÅVed å dobbeltklikke på repository-navnet i «Git Repositories»-panelet så 
åpner det en «GitProjects» arkfane i EG.
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Sjekk inn det nye EG prosjektet

ÅHer vises en oversikt over filene man har endret eller nye 
filer

ÅVi skal sjekke inn det nye EG prosjektet vårt

ÅVed å klikke «Commit» så markeres filen som «Staged
Changes»- man må legge inn en kommentar.
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Sjekk inn det nye EG prosjektet

ÅHer vises en oversikt over filene man har endret eller nye 
filer

ÅVi skal sjekke inn det nye EG prosjektet vårt

ÅVed å klikke «Commit» så markeres filen som «Staged
Changes»- man må legge inn en kommentar.
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Sjekk inn det nye EG prosjektet

ÅHer vises en oversikt over filene man har endret eller nye 
filer

ÅVi skal sjekke inn det nye EG prosjektet vårt

ÅVi har kun en fil som skal sjekkes inn – så vi trenger ikke å 
gruppere filer som skal sjekkes inn sammen ved å «stage» 
de.

ÅVed å klikke «Commit» sjekkes filen inn i lokalt repository. 
NB! Man må legge inn en kommentar for å kunne sjekke 
inn
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Historikk

ÅMan kan se historikken til repositoriet:
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Remote Repository

ÅEtter innsjekkingen (commit) så er filen kun sjekket inn i lokalt repository
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Remote Repository

ÅFørst må man hente evt nye versjoner av filer fra remote repository

ÅPull

ÅHenter filer fra remote og oppdaterer lokalt for å sikre at du har siste versjon av 
filene.

ÅDersom du har gjort endringer lokalt så vil Git sammenflette (merge) innholdet 
fra remote med dine lokale filer

ÅFor binære filer så vil ikke en slik merge finne sted og man får en unresolved
conflict. Kommer tilbake til hvordan man løser opp denne

ÅFetch

ÅHenter filer fra remote, men gjør ingen merge.
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Pull

ÅVi har en ny lokal fil og gjør en pull før vi kan sjekke inn denne remote
(push). Dette i tilfelle noen andre har laget en fil med samme navn og 
«push»-et den til remote repositoriet vårt.

ÅIngenting skjer om det ikke har vært noen endringer siden forrige pull 
eller clone.



Copyright  © SAS Inst itute  Inc.  A l l  r ights reserved.

Push
Synkroniser lokale filer med remote repository

ÅClick «Push»

ÅSjekk remote repository
og se at ny fil ligger der
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Gjøre endring i EG prosjektet
Commit–pull –push

ÅFjerner en node i EG prosjektet

ÅLagrer prosjektet (ctrl-s)

ÅGår inn på GitProjects og ser at det ligger 1 commit klar

ÅSkriver en kort kommentar og «Comitt»-er prosjektet
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Gjøre endring i EG prosjektet
Commit–pull –push

ÅVi klikker «Pull» for å sjekke etter nye filer i remote repository

ÅIngenting skjer om ingen endringer
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Gjøre endring i EG prosjektet
Commit–pull –push

ÅVi klikker «Push» for å synkronisere våre lokale endringer mot remote
repository

ÅTar noen sekunder pga nett, men ingen tilbakemelding om det ikke er 
noen konflikter.

ÅLokalt repository Remote repository
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Konflikter med remote
Binærfiler (EG-prosjektfil)

ÅFor å simulere dette så har jeg clonet en annen lokal kopi av repositoriet

ÅDer har jeg kopiert NetflixHistory81.egp over på NetflixHistory82.egp

ÅJeg commiter – puller – pusher denne for å få en annen versjon inn på 
remote repository
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Konflikter med remote
Binærfile(EG prosjektfil)

ÅJeg gjør en liten endring i min lokale kopi (legger til en kommentar)

ÅLagrer endringen

Nå har jeg en versjon remote som er nyere enn mitt utgangspunkt og jeg 
har en lokal versjon som er nyere enn den remote.

ÅJeg gjør en commit (ingen meldinger)

ÅJeg må gjøre en pull før jeg push-er min versjon, ellers får jeg 
feilmeldingen:
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Konflikter med remote
Binærfile(EG prosjektfil)

ÅJeg gjør en liten endring i min lokale kopi (legger til en kommentar)

ÅLagrer endringen

Nå har jeg en versjon remote som er nyere enn mitt utgangspunkt og jeg 
har en lokal versjon som er nyere enn den remote.

ÅJeg gjør en commit (ingen meldinger)

ÅDersom jeg gjør en push nå (før jeg gjør en pull) får jeg feilmeldingen:
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Konflikter med remote
Binærfile(EG prosjektfil)

ÅDersom jeg forsøker å gjøre en pull med prosjektet åpent i EG får jeg 
følgende feilmelding:

ÅVi må altså lukke EG prosjektet (File->Close projects) vårt før vi kan «pull» 
ny versjon fra GitHub. 
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Konflikter med remote
Binærfile(EG prosjektfil)

ÅSom forventet får vi en merge-conflict (Git klarer ikke å sammenflette to 
binærfiler) og vi må løse opp i denne selv:
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Konflikter med remote
Binærfile(EG prosjektfil)

ÅVi kan se på «History» for å se hva som har skjedd:

ÅVår oppdaterte lokale fil ligger i «master», mens den vi har hentet ligger i 
«origin/master» grenen.
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Konflikter med remote
Binærfile(EG prosjektfil)

ÅVi ønsker at vår versjon skal gjelde – og skal overskrive den på remote.

ÅDa går vi tilbake til «Commit»-fliken og så flytter vi filen fra «unstaged» til 
«staged» som «signal» på det vår lokale versjon er «merged»

ÅDa vil siden se «blank» ut uten noe i «unstaged» og «staged»

ÅVi kan nå gjøre en «Push» på nytt og den vil gå igjennom uten noe 
tilbakemelding.
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Konflikter med remote
Binærfile(EG prosjektfil)

ÅOm vi ser på historikken på nytt så ser vi dette – «master» og 
«origin/master» er slått sammen igjen:
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Konflikter med remote
Binærfile(EG prosjektfil)

ÅPå GitHub ser historikken slik ut:
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Eksempel med programfil

ÅLag ny kodenode i EG8.2

Å«Commit» den inn i EG8.2

ÅPush til remote

ÅEn annen lager en ny versjon og «commit» og push-er den til remote
(simuleres ved å gjøre det fra et annet lokalt repository med en annen 
klient)

ÅGjør endringer i koden i EG8.2

Å«Commit» og forsøk å push-e den.

ÅGjør en pull og se på mergingen før man «Commit» og push-er siste 
mergede endring
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Problemstillinger

ÅProsjektfilen (og evt andre binærfiler som datasett)
ÅInneffektiv lagring i repositoriet om de er store

ÅIngen merging – mye manuell jobb å sette sammen to separate versjoner til en 
versjon – essensielt må man lage en tredre versjon som inkluderer alle 
endringer

ÅLøsninger:
ÅUnngå konflikter ved arbeidsplanlegging og kommunikasjon.

ÅBruke egne versjonskontrollsystemer eller Git-lsf utvidelse der man kan låse en 
fil ved utsjekking og åpne den igjen etter innsjekkingen – dermed må andre 
vente på tur og man fremtvinger sekvensielle endringer.

ÅGjør alt man skal endre til eksterne kodenoder. Mindre sjanse for konflikter og 
seneste versjon av EG prosjektet er oftere det riktige. Ulempe ved at enkelte 
endringer blir tyngre å gjøre (lettere å endre felter i en import-node enn endre 
koden)

ÅAnnet?
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Spørsmål
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