SAS Enterprise Guide: Scheduling Projects




What is SAS Enterprise Guide scheduling?

- Schedule task on the File menu in SAS Enterprise Guide (EG)

« Schedule task creates a VBScript file

- VBScript file allows the EG project to
run “batch”

R

In order to schedule a project or process flow, the project must be saved to your local computer.
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What is SAS Enterprise Guide scheduling?

- Developed for use with Windows Task Scheduler
- Tested using Windows Task Scheduler before release
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Scheduling projects and process flows

In SAS Enterprise Guide, you can use the Microsoft Windows Task Scheduler to schedule projects and process flows to run at a specified time or as the result of a system event. By default,
when you open the Task Scheduler, a script is automatically created in SAS Enterprise Guide to run the project or process flow. When you schedule the project or process flow, the Task
Scheduler creates a scheduled task that includes the script and the criteria that specify when the task should be run. The scheduled task is added to the project tree.

@You must save the project to your local computer before you can create a scheduled task.

To schedule a project or process flow

1. To schedule a project, select File » Schedule project-name.

EA‘“'"QNES toag To schedule a process flow, open a process flow and perform either of the following tasks:
8 Copying items in = Right-click on the name of the process flow in the project tree and select Schedule process-flow-name.
8 Renaming a projs = Right-click in the process flow and select Schedule process-flow-name.

Creating notes fo) An interface to the Microsoft Windows Task Scheduler opens.
[£] Viewing note proj

. On the General tab, you can change the default name of the Task Scheduler task by entering a new name in the Name box. The task name must be unique. You can also enter or

) Previewing files 2. On the G I tab, h the default f the Task Scheduler task by ent: the N box. The task t b Y I t
E Printing files change any of the other properties on the General tab. By default, the scheduled task runs using the account of the user who scheduled the task.

Viewing project p
[] Understanding sz 3. On the Triggers tab, you can specify the triggers, or criteria, that are used to start the scheduled task. Triggers can be time based or event based. For example, time-based triggers
[E] Saving and closit can start the task at a specific time of day or on a regular, repeated schedule. Event-based triggers start the task as a result of a system event, such as when a user logs on or when
E Enabling projects the computer enters an idle state. By default, the task is scheduled to run every day at the current time. If a task has more than one trigger, it starts when any of the triggers occur.

Running a projec
[£] Sending a projec 4. On the Actions tab, you can specify one or more actions that are performed when the task is run. By default, the scheduled task runs the project or process flow. The default action
[E] Viewing the SAS is Start a program, and the default program or script is the generated script file. To run a different script, select the script and click Edit. To add another action, click New.
5] Viewing the SAS
(12 Sending e-mail a 5. On the Conditions tab, you can specify conditions that control whether the task is run. The conditions are evaluated after a task is triggered to start.

Recovering a prc
g Perfmmmggpm;;el 6. On the Settings tab, you can specify options for how the task is run, stopped, or deleted.
L1 Warking with proc 7. On the Run Times tab, you can view a list of the times that the task is scheduled to run. On the History tab, you can view a list of the times that the task has run.
[£] Creating an order

E @ Automating Proje 8. To save the scheduled task, click OK. The scheduled task and the associated script are added to the project tree.

To run a scheduled project or process flow

* Close the project so that the results of the scheduled task can be saved. If you scheduled a task for a process flow, close the project that contains the process flow.

To edit a scheduled task

* Right-click the scheduled task in the project tree and select Open scheduled-task-name. The scheduled task opens in the Task Scheduler.
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What is SAS Enterprise Guide scheduling?

« Schedule task opens Windows Task Scheduler ‘Create Task’ dialog
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SAS Report -
Program
Schedule - class Properties (Local Machine) IS [=]
General | Triggers | Actions | Conditions | Settings | Run Times | History |
MName: IScheduIe - class
Location: \
Author: sas
Description:

Security options

When running the task, use the following user account:

ISASBl\sas
& Run only when user is logged on

" Run whether user is logged on or not

Il only have acc

™| Run with highest privileges

o local computer resources,

Change User or Group,

™ Hidden Configure for: Windows Server™ 2003, Windows® XP, or Windows® 2000 j
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What is SAS Enterprise Guide scheduling?

- ‘Create Task’ dialog in Windows Task Scheduler
- Job runs under current Windows ID

@ Task Scheduler
File Action View Help
L el
© sk SiE‘f;'e’; ﬂ"“cag Name | status [ Triggers | Next Run Time [ Last Run Time | Last Run Result
ol oSz (% Adobe Flash ... Ready At 7:04PM every 7 days - After triggered, repeat every 1 hour for a duration of 1day. 10/12/2018 8:0400PM  10/8/2018 10:01:01 AM  The operation com
(%) Adobe Flash ... Ready At 7:10 PM every day - After triggered, repeat every 1 hour for a duration of 1 day. 10/12/2018 12:10:00 PM 10122018 11:09:59 AM The operation com
(% GoogleUpdat... Ready Multiple triggers defined 10/12/2018 1:42:01PM  10/11/2018 1:42:01PM  The operation com
(%) GoogleUpdat... Ready At 1:42PM every day - After triggered, repeat every 1hour for aduration of 1day.  10/12/2018 11:42:01 AM  10/12/2018 10:42:01 AM The operation com
(T lasrLoad Ready 9/5/2018 10:37:52 AM The operation com
(® 5chedule - dass Ready At 12:05PM on 10/10/2018 10/10/2018 12:05:00 PM  The operation com
(% User_Feed_S... Ready At 11:13 AMevery dav - Trioger expires at 5/12/2028 11:13:32 AM. 10/12/2018 11:13:32 AM _ Never
(I S NI TR @ Schedule - class Properties (Local Computer) :39PM  The operation com
(i User_Feed S... Ready A
(T User_Feed ... Ready # General | Triggers | Actions | Conditions | Settings | History (disabled) | 40AM  The operation cor
Name: IScheduIe- class

Location: %

Author: sas

Al Desciption: || _ Eaa

General | Triggers | Actions

Mame: Schedule - ¢

Location:  \ Security options

Author: sas When running the task, use the following user account:

Description: SASBDNsas Change User or Grou|
' Run only when user is logged on
€ Run whether user is logged on or not
I Do not store password. The taskwill enly have access to local computer resources.
™ Run with highest privileges
™ Hidden Configure for:  |Windows Server™ 2003, Windows® XP, or Windows® 2000 j
Cancel

Security options
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What is SAS Enterprise Guide scheduling?

VBScript file

- Correct version of EG Scripting Model, SASEGScripting.dll

- Installed and registered

- Path and name of project

Option Explicit
Dim app

Call dowork

'shut down the app

If not (app Is Nothing) Then
app.Quit
Set app = Nothing

End If

Sub dowork()
On Error Resume Next

' Start up Enterprise Guide using the project name

Dim priName
Dim priobject

| priName = "C:\Users\sas\Projects\&Ask the Expert\class.egp"

| 'Project Name

| Set app = CreateObject ("SASEGObjectModel.Application.7.1")

If Checkerror ("CreateObject"™) = True Then
Exit Sub
End If

Set pricbject = app.Open(privName,"")

If Checkerror("app.Open") = True Then
Exit Sub
End If
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What is SAS Enterprise Guide scheduling?
VBScript file

- When debugging, use the script for help!

= e
prijobject.Save

If Checkerror("Project.Save") = True Then
Exit Sub
End If

priobject.close

If Checkerror("Project.Close") = True Then
Exit Sub

End If

End Sub

Function Checkerror (£nName)
Checkerror = False

Dim strmsg
Dim errNum

If Err.Number <> 0 Then
trmesg = "Error AV g Hex(Frr Mumberl £ sborlf £ N"Ion Fupctiopn " o foName £ ybhorlf g Frr Deccrintion
'MsgBox strmsg 'Uncomment this line if you want to be notified via MessageBox of Errors in the script.
CHECKerror = Irue
End If

End Function
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Why schedule an EG project?

- Automate analysis of new data
- Automate report distribution
-« Improve project execution performance because Ul is not active

- Send automated “good morning” text to your children letting them know
how many days are left in the school year

- And many more...
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DEMOS

“Help! | can’t schedule SAS Enterprise Guide projects!”




1. Can you execute an EG project in batch?
- Create simple project
- Enable application logging
- Use schedule task to create VBScript
- Uncomment MsgBox in the VBScript file

« Run VBScript outside of scheduler
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2. Can your Windows ID execute non-SAS VBScripts?

- Cannot execute a non-SAS VBScript? Then the EG-created VBScript will

not execute as well.
- Sample code

Call sendmail

Sub sendmail ()
Dim objMessage
Set objMessage =
With objMessage

CreateObject ("CDO.Message")

.Subject = "Test"

.From = "your-email@company.com"

.To = "your-email@company.com"

.TextBody = "Test email from VBScript is successful."
.Configuration.Fields.Item ("http://schemas.microsoft
.Configuration.Fields.Item ("http://schemas.microsoft
.Configuration.Fields.Item ("http://schemas.microsoft

.Configuration.

End With
objMessage.Send
Set objMessage =
Wscript.Quit
End sub

Fields.Update

Nothing

.com/cdo/configuration/sendusing") = 2

.com/cdo/configuration/smtpserver") = "emailservername.company.com"

.com/cdo/configuration/smtpserverport")
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3. Can your Windows ID schedule non-SAS VBScripts?

« Use Windows Task Scheduler to schedule the sample code on the
previous slide

- If your Windows ID cannot schedule the sample code successfully, talk to
your IT department.
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4. Can your Windows ID access the EG Automation Interface?

- Sample code taken from https://github.com/cjdinger/sas-eg-

automation/blob/master/vbscript/NewApp.vbs

Option Explicit
Dim Application

' Create a new SAS Enterprise Guide automation session

Set Application = WScript.CreateObject ("SASEGObjectModel.Application.7.1")

WScript.Echo Application.Name & ", Version: " & Application.Version

Application.Quit
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https://github.com/cjdinger/sas-eg-automation/blob/master/vbscript/NewApp.vbs

4. Can your Windows ID access the EG Automation Interface?
Error caused by one of the following:

1.  EG automation object model needs to be registered:
https://communities.sas.com/t5/SAS-Enterprise-Guide/VBScript-error-
could-not-locate-automation-class/td-p/103212

2. VBScript (.vbs) files are associated with the wrong Windows Script Host
on the Windows Machine. The bitness of cscript.exe must match the
bitness of SAS Enterprise Guide.

- Have Admin register .vbs files to correct cscript.exe
- Use path to correct cscript in command to execute VBScript file

3. Your Windows ID is denied the ability to run scripts.
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https://communities.sas.com/t5/SAS-Enterprise-Guide/VBScript-error-could-not-locate-automation-class/td-p/103212

5. Using “Run only when user is logged on”
SAS Note 56648: Tips for scheduling

http://support.sas.com/kb/56648

The recommended and default Windows Task Scheduler security setting for running SAS Enterprise Guide
projects is Run only when user is logged on.

The Windows user must be able to use Windows Task Scheduler. The user must be able to execute VBScript
programs independently of SAS Enterprise Guide.

Metadata credentials must be cached in the SAS Enterprise Guide user's connection profile. To see this
information, navigate to Tools » Connections. Choose the active server and click Modify to open the Connection
profile. Make sure that the Save login in profile option is checked and that the selection persists. If it does not
persist, contact your SAS” metadata administrator and request the ability to cache metadata credentials.

Credentials must persist throughout the SAS Enterprise Guide session. To check this setting, navigate to Tools P
Options P Security. The option Credentials Persistence must be set to Persist during EG session.

A scheduled project does not execute if the project is open. Ensure that you have saved and closed the project
before it is scheduled to execute in batch.

SAS Enterprise Guide must be installed on the machine where the VBScript file is scheduled to execute.
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6. Using “Run whether user is logged on or not”

SAS Note 56648: Tips for scheduling
http://support.sas.com/kb/56648

Use of this security context depends on Windows settings, not SAS Enterprise Guide settings. As these
settings vary based on company security policies, it is often difficult to use this Task Scheduler security
context. For example, it might be allowed due to company restrictions.

The Windows user ID that is used to schedule the project must have Local Administration rights and
the Log on as a batch job privilege.

« You will likely need to open SAS Enterprise Guide using "Run as Administrator" before using the Schedule
task. Windows 8 and later operating systems do not open applications using Administrator privileges by
default. Because Run whether user is logged on or not requires Administrator privileges, SAS Enterprise
Guide must be opened with elevated Admin rights.

« The project and VBScript must be saved to your local computer (not a network drive or SharePoint, and so
on.) to use the Run whether user is logged on or not security option.

« To use the Run whether user is logged on or not Task Scheduler security context, select File » Schedule
Project. On the General tab, deselect the option Do not store password. The Run with Highest
Privileges option might or might not be needed. Test with this option selected and without it selected.
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http://go.documentation.sas.com/?docsetId=scheduleug&docsetTarget=n05akp7m9jxhzfn1coz5nepy7zxf.htm&docsetVersion=9.4&locale=en#n1j8cmhtbn1n1mn1ga01fb6m4izf

6. Using “Run whether user is logged on or not”

SAS Note 56648: Tips for scheduling
http://support.sas.com/kb/56648

On the General tab, select Windows Server 2003, Windows XP, or Windows 2000 for the Configure
for option.

« When you click OK in the Task Scheduler dialog box, you are prompted to enter a Windows user ID and

password. On the Triggers tab, specify when Task Scheduler should execute the project. A .vbs file is
added to the project. Save the project and close it so that it can be successfully executed in batch as
scheduled.

For a project to Run whether user is logged on or not, it might be necessary to copy

the ConfigurationVxx.xml file, where xx is the version of SAS Enterprise Guide, from

the %appdata%\SAS\MetadataServerProfiles folder into

the C:\Windows\System32\config\systemprofile\AppData\Roaming\SAS\MetadataServerProfiles folder or
the C:\Windows\SysWOW&64\config\systemprofile\AppData\Roaming\SAS\MetadataServerProfiles folder.

For access to network resources when Run whether user is logged on or not is selected, you must disable
the Windows local security option Network access: Do not allow storage of passwords and credentials for
network authentication.
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SAS Enterprise Guide: Scheduling Projects

References

- EG Scheduling Video Tutorial,
https://video.sas.com/detail/videos/working-with-sas-enterprise-
oguide/video/3862944641001/use-the-scheduling-features-of-sas-
enterprise-guide?autoStart=true&page=1

Doing More with EG Automation by Chris Hemedinger,
https://blogs.sas.com/content/sasdummy/2012/04/17/doing-more-with-

sas-enterprise-guide-automation/

- Windows Task Scheduler documentation (hard to find),
https://docs.microsoft.com/en-us/windows/desktop/taskschd/using-the-
task-scheduler

Tips for Scheduling a SAS Enterprise Guide Project, SAS Note 56648,
http://support.sas.com/kb/56648
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QUESTIONS




What steps do we need to take if the workspace
server is configured to prompt for userid and
password?

« Follow the instructions in SAS Note 30917 to create a credentials.xml file,
http://support.sas.com/kb/30917
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What do | do if my SAS metadata userid and
password will not save in my connection profile?

 Your SAS administrator will need to enable client-side caching for your
metadata credentials.

« SASSEC_LOCAL_PW_SAVE option in the omaconfig.xml file on the SAS
Metadata Server,

https://go.documentation.sas.com/?docsetld=bisag&docsetTarget=n070f
n7royuz53n19c7180f3hrlg.htm&docsetVersion=9.4&locale=en
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Can | schedule a process flow instead of a project?

* YES!

- Right-click on the Process Flow name in the Project Tree window and
choose “Schedule Process Flow”.

scheduletest - SAS Enterprise Guide

File Edit View Tasks Favorites Program Tools Help ‘

|Broject ree N Process Flow -

=} Evgw ' .
=-L1 Pro Run Process Flow b Run - @ Stop | Bxp
&1 Schedule Process Flow.. | ®
- [# Create Stored Process @ @
Program SAS Rey
=L@ Sched Copy kS —ngr;
EIEE %: NEm  Paste
X Delete @
Rename Program (2)
Properties
2

Gsas



| get an “Access Denied” error when | try to schedule
a project. What does this mean?

- Either your userid cannot schedule anything in Windows Task Scheduler
« Or your ID needs admin rights to do access Windows Task Scheduler

« Oryou need to start EG using “Run as Administrator” before you use the
Schedule task, http://support.sas.com/kb/59079
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